Bug 217428 - rescue mode fails: 'NoneType' object has no attribute 'keys'
rescue mode fails: 'NoneType' object has no attribute 'keys'
Status: CLOSED DUPLICATE of bug 217376
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
: Regression
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2006-11-27 16:17 EST by Doug Chapman
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-28 13:45:11 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2006-11-27 16:17:54 EST
Description of problem:
booting rawhide rescue mode on ia64 fails with:


Running anaconda, the Fedora Core rescue mode - please wait...
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 741, in ?
    anaconda.id = instdata.InstallData([], "fd0", anaconda.methodstr,
opts.display_mode)
  File "/usr/lib/anaconda/instdata.py", line 281, in __init__
    self.reset()
  File "/usr/lib/anaconda/instdata.py", line 70, in reset
    self.bootloader = bootloader.getBootloader()
  File "/usr/lib/anaconda/bootloader.py", line 207, in getBootloader
    return booty.getBootloader()
  File "/usr/lib/booty/booty.py", line 37, in getBootloader
    return ia64BootloaderInfo()
  File "/usr/lib/booty/bootloaderInfo.py", line 615, in __init__
    bootloaderInfo.__init__(self)
  File "/usr/lib/booty/bootloaderInfo.py", line 481, in __init__
    self.updateDriveList()
  File "/usr/lib/booty/bootloaderInfo.py", line 445, in updateDriveList
    self.drivelist = self.createDriveList()
  File "/usr/lib/booty/bootloaderInfo.py", line 436, in createDriveList
    drives = isys.cachedDrives.keys()
AttributeError: 'NoneType' object has no attribute 'keys'
install exited abnormally [1/1]

Version-Release number of selected component (if applicable):
rawhide-20061127
anaconda-11.2.0.1-1


How reproducible:
100%

Steps to Reproduce:
1. boot rescue mode
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jeremy Katz 2006-11-28 13:45:11 EST

*** This bug has been marked as a duplicate of 217376 ***

Note You need to log in before you can comment on or make changes to this bug.