Bug 217469 - setting copy=yes uses wrong mailbox for Fcc
Summary: setting copy=yes uses wrong mailbox for Fcc
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mutt   
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Miroslav Lichvar
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-28 01:22 UTC by David Alden
Modified: 2014-07-29 10:59 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-07-29 10:59:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Alden 2006-11-28 01:22:02 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en) AppleWebKit/418.9 (KHTML, like Gecko) Safari/419.3

Description of problem:
When I  add "set copy=yes" to my muttrc, the default Fcc folder is adding "=/<username>" instead of 
"=<username>" (it's adding a "/" after the equal sign).

Version-Release number of selected component (if applicable):
mutt-1.4.2.2-4.fc6

How reproducible:
Always


Steps to Reproduce:
1. Add "set copy=yes" to muttrc
2. Send a message to yourself
3. Look at the Fcc entry.

Actual Results:
The Fcc entry is "=/<username>"

Expected Results:
The Fcc entry should have been "=<username>"

Additional info:

Comment 1 Miroslav Lichvar 2006-12-05 12:25:17 UTC
Can you post more from your .muttrc?

Relevant variables are save_name, record, force_name and command fcc-hook.

Comment 2 David Alden 2006-12-05 13:35:14 UTC
It seems to be the combo of imap and force_name.  I've narrowed it down to a .muttrc containing just:

set spoolfile=imaps://mail.math.ohio-state.edu/INBOX
set folder=imaps://mail.math.ohio-state.edu

set force_name


Without the imap stuff it works fine, with it it adds the "/".

Comment 3 Miroslav Lichvar 2006-12-06 17:44:16 UTC
Ok, thanks. This was fixed upstream in mutt-1.5.3, the patch is in
mutt-1.4.2.2-5.fc6.

Comment 4 jpacner 2014-07-23 14:08:05 UTC
List of patches present on mutt-1.5.20-6.20091214hg736b6a.el6:
http://pkgs.devel.redhat.com/cgit/rpms/mutt/commit/?h=rhel-6.6&id=1ee912e0d9d73efadd493aef4a9c323905603b08

Comment 5 jpacner 2014-07-29 10:59:05 UTC
Recovering from unwanted changes caused by a badly chosen bug number choice.


Note You need to log in before you can comment on or make changes to this bug.