Bug 217478 - wesnoth very slow in windowed mode due to SDL scaling
Summary: wesnoth very slow in windowed mode due to SDL scaling
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: wesnoth   
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Brian Pepple
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-28 02:57 UTC by Rik van Riel
Modified: 2007-11-30 22:11 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-28 04:24:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rik van Riel 2006-11-28 02:57:50 UTC
Description of problem:

Sometimes Wesnoth runs just fine in windowed mode, however sometimes the size of
the Wesnoth window and the Wesnoth game resolution are not the same and SDL
scaling happens.

When that happens, the CPU use of my X server goes over 90% and still the screen
only updates two or three times a second.  Totally unplayable :(

Version-Release number of selected component (if applicable):

wesnoth-1.0.2-3.fc6

Steps to Reproduce:
1. play wesnoth in windowed mode
2. resize the window
3. suffer
  
Expected results:

Wesnoth should either refuse to have its window resized to unplayable
resolutions, or it should make sure the image is scaled in a faster way.

Additional info:

1) I do NOT resize the window myself.  Wesnoth for some reason starts up with
the window the wrong size.  I even removed the window resolution bits from the
configuration file to try and fix things, and it STILL picked the wrong resolution!

2) due to my Xinerama (well, Radeon mergedfb) setup, I cannot play wesnoth full
screen

3) maybe wesnoth should not allow scaling the window to "bad" resolutions?

Comment 1 Rik van Riel 2006-11-28 04:24:02 UTC
Upgrading SDL fixed this issue...


Note You need to log in before you can comment on or make changes to this bug.