This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 217511 - rhythmbox hang
rhythmbox hang
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: rhythmbox (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-28 06:29 EST by Joe Orton
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.9.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-30 10:43:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
backtrace from hung rhythmbox (37.69 KB, text/plain)
2006-11-28 06:32 EST, Joe Orton
no flags Details

  None (edit)
Description Joe Orton 2006-11-28 06:29:42 EST
Description of problem:
rhythmbox seems to go into an infinite loop occasionally on my box.
Playing MP3s off an NFS mount.  I don't know what triggers it.  I SEGVed it and
will attach a backtrace.

Version-Release number of selected component (if applicable):
rhythmbox-0.9.5-4.fc6.x86_64
Comment 1 Joe Orton 2006-11-28 06:32:30 EST
Created attachment 142277 [details]
backtrace from hung rhythmbox

The rhythmbox UI is completely unresponsive in this state.
Comment 2 Alexander Larsson 2006-11-28 08:35:22 EST
Strange. Seems to be in some python code.
Comment 3 Matthias Clasen 2006-11-28 08:42:25 EST
Look at frame #2. It seems to scale down a pixbuf to a teeny size. 
gdk-pixbuf is known to use gobs of memory in this case. 
Is your rhythmbox process eating up all memory at this point ?
Comment 4 Joe Orton 2006-11-28 08:54:26 EST
I didn't notice; the core dump is 190Mb in size.  If I SEGV a happily-running
rhythmbox it only comes in at ~100Mb, FWIW.

I may only have started seeing this since enabling the "Art Display" plugin.
Comment 5 Alexander Larsson 2006-11-28 09:14:21 EST
Yes, 300x300 -> 1x1
1x1 is probably the size of some hidden widget or something.
Comment 6 Joe Orton 2006-12-05 07:23:22 EST
This happened again - and it does recover after 5+ minutes of eating CPU - the
resident set size was increasing at a rate of about a meg every 15 seconds or so
during that time, according to top.
Comment 7 Bastien Nocera 2007-01-30 10:43:31 EST
Yeah, that would be the old gdk-pixbuf 1x1 resizing bug.

Filed against Rhythmbox at:
http://bugzilla.gnome.org/show_bug.cgi?id=343345

Fixed in:
2006-07-09  James Livingston  <doclivingston@gmail.com>

        * plugins/artdisplay/artdisplay/__init__.py: some minor changes to try
        to prevent #343345:
                - don't ever scale to 1x1, just hide the image in that case
                - don't fade when the window is minimised
                - use the last-good allocation width, not the current one - as
                  it sometimes get weird values.

Should be fixed in the current FC6 update.

Note You need to log in before you can comment on or make changes to this bug.