This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 217517 - A new stable gthumb release is available
A new stable gthumb release is available
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gthumb (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Behdad Esfahbod
:
Depends On:
Blocks: FC6Update
  Show dependency treegraph
 
Reported: 2006-11-28 07:49 EST by Michael J. Chudobiak
Modified: 2008-02-06 00:18 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-06 00:18:48 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michael J. Chudobiak 2006-11-28 07:49:39 EST
The current stable gthumb release is 2.8.0. It is a bug-fix release that fixes
this critical crasher bug, which has been widely reported on FC6 systems (see
gnome bugzilla):

http://bugzilla.gnome.org/show_bug.cgi?id=356623

as well as a serious memory leak when scaling images:

http://bugzilla.gnome.org/show_bug.cgi?id=349576

and some other minor issues. I suggest that you update FC6 gthumb to 2.8.0.

The development 2.9.0 series has not been released yet.

- Mike
Comment 1 Michael J. Chudobiak 2007-01-05 10:47:37 EST
gThumb 2.9.1 [development] is now available, as is 2.8.1 [stable]. See
http://gthumb.sourceforge.net.

The 2.7.x series is obsolete.

- Mike
Comment 2 Julien Tognazzi 2007-01-31 09:42:42 EST
Yes, please upgrade for FC6.
The current version also suffer from a bug with rotated images, which makes it
impossible to use f-spot and gthumb at the same time.
see:
http://bugzilla.gnome.org/show_bug.cgi?id=361913
http://bugzilla.gnome.org/show_bug.cgi?id=343867

Comment 3 Michael J. Chudobiak 2007-01-31 10:13:11 EST
The 2.8.1 version is a very minor upgrade from the existing 2.7.x version. It is
a bug-fix only release (with no changes in dependencies), and it should be
simple to upgrade the existing rpm for FC6.

The 2.8.1 fixes the rotation problem, as well as the crasher bugs mentioned above.

Please upgrade the FC6 release to 2.8.1.

I am very pleased to see that the FC7 development repos have 2.9.1.

- Mike (a gthumb coder)
Comment 4 Michael J. Chudobiak 2007-03-19 15:46:01 EDT
Please, please, pretty please upgrade the FC6 release of gthumb to 2.8.1.

I've been triaging an endless number of duplicate bug reports for gnome bug
356623 (http://bugzilla.gnome.org/show_bug.cgi?id=356623), mostly from FC6
users. 2.8.1 fixes that.

- Mike
Comment 5 Behdad Esfahbod 2007-04-02 13:48:25 EDT
(In reply to comment #3)
> The 2.8.1 version is a very minor upgrade from the existing 2.7.x version. It is
> a bug-fix only release (with no changes in dependencies), and it should be
> simple to upgrade the existing rpm for FC6.
> 
> The 2.8.1 fixes the rotation problem, as well as the crasher bugs mentioned above.

In that case, it was named very badly.  I would have upgraded instantly if it
was called 2.7.x, but with 2.8.1, I have to make sure:

  - dependencies are still satisfied for 2.8.1
  - no library .so versions changed in between
  - no serious changes in the UI, etc

only after these I can push it in FC6...

Why is it called 2.8.x instead of 2.7.x?

> Please upgrade the FC6 release to 2.8.1.
> 
> I am very pleased to see that the FC7 development repos have 2.9.1.
> 
> - Mike (a gthumb coder)

Comment 6 Michael J. Chudobiak 2007-04-02 14:09:17 EDT
I don't decide gThumb releases, however, I think that the general idea was that
2.8.x was the stable termination of the 2.7.x development series. Only important
bug fixes went into 2.8.x once it was created. As it happens, the bugs were
important/frequent enough to hassle you :-)

New features went into 2.9.x (unstable), which has now terminated in the 2.10.x
stable series.

My apologies if that approach caused problems...

- Mike
Comment 7 Matthias Clasen 2008-02-06 00:18:48 EST
Closing this, since FC6 is no longer supported. Newer gthumb versions are in
later releases.

Note You need to log in before you can comment on or make changes to this bug.