Bug 217532 - Share contents not visible using mount cifs
Share contents not visible using mount cifs
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Layton
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-28 09:30 EST by Bob Peers
Modified: 2014-06-18 03:35 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-19 14:42:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg output (2.83 KB, text/plain)
2006-12-09 15:23 EST, Bob Peers
no flags Details
dmesg output of ls on a known file (1.69 KB, text/plain)
2006-12-09 15:25 EST, Bob Peers
no flags Details

  None (edit)
Description Bob Peers 2006-11-28 09:30:48 EST
Description of problem:
I'm trying to mount a Synology NAS device using cifs. I can successfully mount
the share and create new files however I cannot view any files on the device.
Both Nautilus and the command line show no folder contents but if I try to
create a new file of folder of the same name as an existing one it recognizes
the filename already exists.


Version-Release number of selected component (if applicable):


How reproducible:
Every time


Steps to Reproduce:
1.Mount the share:
$ sudo mount -t cifs //192.168.1.108/web /mnt/DiskStation/ -o
user=bobuser,pass=berg16,rw,dom=bergnet

2.Change to directory:
$ cd /mnt/DiskStation/

3.ls shows no contents:
[bobuser@linux DiskStation]$ ls -l
total 0

4.Make folder with same name as one I know exists:
$ mkdir photos
mkdir: cannot create directory `photos': File exists

5. Make a new folder I know doesn't exist:
[bobuser@linux DiskStation]$ mkdir bugzilla
[bobuser@linux DiskStation]$ ls
[bobuser@linux DiskStation]$ ls -l
total 0

ls still shows no contents even though the folder bugzilla was successfully created.

6.du shows the correct used space on the share:
$ df|grep Disk
//192.168.1.108/web  307007444   9814732 297192712   4% /mnt/DiskStation  

Actual results:
Cannot see share contents

The only entry in /var/log/messages is:
Nov 28 15:12:01 linux kernel: SELinux: initialized (dev cifs, type cifs), uses
genfs_contexts
No errors at all.
Expected results:
Should see a listing of the shares contents

Additional info:
Comment 1 Bob Peers 2006-11-28 09:45:09 EST
Forget to add using samba:
samba-client-3.0.23c-2

kernel:
2.6.18-1.2849.fc6
Comment 2 Shirish S. Pargaonkar 2006-12-09 12:55:10 EST
On the FC6 client machine, can you mount the share, issue commands
 echo 1 > /proc/fs/cifs/cifsFYI
 dmesg -c
issue command like
 ls -l /mnt/DiskStation
and then send dmesg log.

And you can repeat above after unmounting the share with a slight change i.e.
issue a command like
 ls -l /mnt/DiskStation/<a_specific_file_name_that_you_know_exists>
and then send dmesg log.

You may also want to issue command 
 echo 1 > /proc/fs/cifs/traceSMB 
besides the above listed echo command.

Comment 3 Bob Peers 2006-12-09 15:23:41 EST
Created attachment 143225 [details]
dmesg output
Comment 4 Bob Peers 2006-12-09 15:25:28 EST
Created attachment 143226 [details]
dmesg output of ls on a known file
Comment 5 Shirish S. Pargaonkar 2006-12-10 15:57:38 EST
I am not too comfortable with this error in dmesg log

 fs/cifs/cifssmb.c: In GetPosixACL (Unix) for path /index.php
 fs/cifs/transport.c: For smb_command 50
 fs/cifs/transport.c: Sending smb of length 94
 fs/cifs/connect.c: rfc1002 length 0x27)
 fs/cifs/connect.c: invalid transact2 word count
 fs/cifs/netmisc.c:  !!Mapping smb error code 124 to POSIX err -95 !!
 fs/cifs/cifssmb.c: Send error in Query POSIX ACL = -95

I encounter similar error on SLES10 1.45 cifs.ko that I am running.  
It does not occur on 1.46 of cifs.ko.

What is the version of cifs.ko that you are running?



Comment 6 Bob Peers 2006-12-10 16:28:15 EST
I'm running 1.45 cifs.ko
Comment 7 Bob Peers 2007-01-21 06:35:02 EST
I've also tried this with version 1.46 of cifs.ko with the same result. It seems
that the server runs samba and the smb.conf file has the setting:

unix extensions=yes

if this is changed to no then there is no problem with seeing the mounted files
and directories.
Comment 8 Jeff Layton 2007-11-18 07:51:15 EST
From comment #5, it looks like the server reporting that it supports unix
extensions, but is sending bogus responses. Is this still a problem on recent
fedora releases?
Comment 9 Bob Peers 2007-11-19 14:35:24 EST
Changing unix extensions=no on the NAS box fixed this. I installed new firmware
on my Synology DS-106e and the problem resolved itself, I guess due to this change.
I now use Fedora 8 but haven't tried to connect to my NAS as of yet but I assume
it now works.
Comment 10 Jeff Layton 2007-11-19 14:42:07 EST
Thanks. I'll go ahead and close this -- please reopen if it still appears to be
an issue...

Note You need to log in before you can comment on or make changes to this bug.