Bug 21754 - Weird reporting problem
Weird reporting problem
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: fileutils (Show other bugs)
6.2
i686 Linux
low Severity low
: ---
: ---
Assigned To: Bernhard Rosenkraenzer
Aaron Brown
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-05 13:36 EST by Ricky Ng-Adam
Modified: 2005-10-31 17:00 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-06 13:18:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ricky Ng-Adam 2000-12-05 13:36:42 EST
Hopefully, this time it is just a bug and not something I don't 
understand...  

As you can see in the following taken at the same time, the information 
differs between df and du :

[root@sonia local]# df -k
Filesystem           1k-blocks      Used Available Use% Mounted on
/dev/sda10              497829    228678    243449  48% /
/dev/sda1                15522      2864     11857  19% /boot
/dev/sda7              2016016   1149508    764096  60% /fs
/dev/sda6              2016016    270416   1643188  14% /home
/dev/sda8              1517920    404312   1036500  28% /usr
/dev/sda5              2016016   2001660         0 100% /usr/local
/dev/sda9               497829     68691    403436  15% /usr/src
[root@sonia local]# du -sk *
16      CLUBS
447436  SONIA
156     backup
832     bin
4       doc
36      etc
4       games
32      include
4       info
712     lib
6968    man
116     sbin
54384   src
16      var

Before taking these measure, I had created massive 1.2Gig iso file by 
mistkae with mkisofs that made my /usr/local full.  I then deleted those 
iso files and was stuck with the results you see above.

Workaround: went init 1 and back to init 3... (Note that I created a 
200Megs file in /usr/local/backup before taking the measures below) and 
everything was fine but still no explanation as to why:

[root@sonia local]# df -k
Filesystem           1k-blocks      Used Available Use% Mounted on
/dev/sda10              497829    226456    245671  48% /
/dev/sda1                15522      2864     11857  19% /boot
/dev/sda7              2016016   1149508    764096  60% /fs
/dev/sda6              2016016    270376   1643228  14% /home
/dev/sda8              1517920    404312   1036500  28% /usr
/dev/sda5              2016016    787992   1125612  41% /usr/local
/dev/sda9               497829     68691    403436  15% /usr/src
/dev/fd0                  1423        84      1339   6% /mnt/floppy
[root@sonia local]# du -sk *
16      CLUBS
447436  SONIA
270488  backup
832     bin
4       doc
36      etc
4       games
32      include
4       info
712     lib
6968    man
116     sbin
54384   src
16      var

Thanks!
Comment 1 Ricky Ng-Adam 2000-12-05 18:35:00 EST
Just a quick note about the output of mkisofs while creating the massive file:

 87.26% done, estimate finish Tue Dec  5 09:15:47 2000
 87.35% done, estimate finish Tue Dec  5 09:15:46 2000
 87.43% done, estimate finish Tue Dec  5 09:15:46 2000
 87.51% done, estimate finish Tue Dec  5 09:15:47 2000
 87.60% done, estimate finish Tue Dec  5 09:15:47 2000
 87.68% done, estimate finish Tue Dec  5 09:15:47 2000
mkisofs: No space left on device. cannot fwrite 32768*1
[root@sonia scripts]#
Comment 2 Bernhard Rosenkraenzer 2000-12-06 11:52:07 EST
Try du -sk . rather than du -sk *... Is there still a difference?
Comment 3 Ricky Ng-Adam 2000-12-06 13:18:05 EST
I can't try it again as I found a workaround to correct it. I tried reproducing 
the problem again (to test it) by re-creating a massive ISO file again. I got 
the same error from mkisofs but upon deleting the file I could not reproduce the 
reporting problem.  Must be a fluke or I'm missing some other condition to 
reproduce it.
Comment 4 Karsten Hopp 2000-12-12 11:35:10 EST
Please reopen this bugreport if you can trigger the reported
behavior again

Note You need to log in before you can comment on or make changes to this bug.