Bug 217554 - Xen HVM: cannot input capital letters using qemu VNC console
Xen HVM: cannot input capital letters using qemu VNC console
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Xen Maintainance List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-28 11:27 EST by Bryn M. Reeves
Modified: 2009-06-19 06:12 EDT (History)
1 user (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-21 07:29:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Prototype patch to fix entering of uppercase letters (1.74 KB, patch)
2006-11-28 17:58 EST, Daniel Berrange
no flags Details | Diff
Patch to fix uppercase handling (1.70 KB, patch)
2006-12-01 10:28 EST, Daniel Berrange
no flags Details | Diff

  None (edit)
Description Bryn M. Reeves 2006-11-28 11:27:02 EST
Description of problem:
When creating a HVM guest under xen it is possible to switch to the qemu monitor
display to configure aspects of the HVM. If using VNC for graphics support all
characters input are transformed to lowercase. 

Version-Release number of selected component (if applicable):
xen-3.0.3-8.el5

How reproducible:
100%

Steps to Reproduce:
1. Configure a HVM guest with vnc graphics enabled:
   builder="hvm"
   ...
   vnc=1
   ...
2. Create the domain via "xm create <domain>"
3. Attach to the domain's console using vncviewer
4. Switch to the qemu monitor with ctrl-alt-2
5. Enter some mixed case characters at the console

  
Actual results:
All input characters are displayed in lowercase.

Expected results:
Characters maintain the proper casing.

Additional info:
The reporter noticed this using virt-manager which always uses VNC to talk to
guest domains but the same problem exists for any domain created using VNC. SDL
domains are not affected.
Comment 1 Daniel Berrange 2006-11-28 12:48:04 EST
I have confirmed this happens both with normal VNC Viewer & virt-manager, so it
looks like an problem with way QEMU is interpretting the keycodes sent, rather
than the client program.
Comment 2 Daniel Berrange 2006-11-28 17:58:25 EST
Created attachment 142339 [details]
Prototype patch to fix entering of uppercase letters

This patch fixes entering of uppercase letters. Has been sent upstream for
review....
Comment 3 Daniel Berrange 2006-12-01 08:53:41 EST
Fix is now accepted upstream

http://xenbits.xensource.com/xen-unstable.hg?cs=582d21e2d3cd

Without this patch, people trying to use the HVM console to map in an alternate
CDROM image will need to rename their ISO images to be all lowercase :-(
Comment 4 Jay Turner 2006-12-01 09:26:17 EST
QE ack for RHEL5.
Comment 6 Daniel Berrange 2006-12-01 10:28:52 EST
Created attachment 142575 [details]
Patch to fix uppercase handling

This is the final patch version which went upstream. Slightly changed to take
acocunt of fact that its impossible to ever receive an uppercase in first
place, so no need to handle conversion back to lowercase for them.

Note You need to log in before you can comment on or make changes to this bug.