Bug 217635 - VTI domain sometimes fails to display SDL graphics window
Summary: VTI domain sometimes fails to display SDL graphics window
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: ia64 Linux
medium
high
Target Milestone: ---
: ---
Assignee: Steven Rostedt
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-29 01:58 UTC by Watanabe Takehiko
Modified: 2018-10-19 19:09 UTC (History)
2 users (show)

Fixed In Version: 5.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-27 04:47:10 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
log files related with xen (185.15 KB, application/x-gzip)
2006-11-29 02:02 UTC, Watanabe Takehiko
no flags Details
the sysreport when the issue occured (489.76 KB, application/x-bzip2)
2006-11-29 02:07 UTC, Watanabe Takehiko
no flags Details

Description Watanabe Takehiko 2006-11-29 01:58:42 UTC
Description of problem:
 When I test keeping create/destroy in VTI domain graphical mode
 (specyfing sdl=1, nographic=0),
 Sometimes qemu-window creation failed at creating VTI domain.
 I try to create VTI domain 618 times and 42 times are failed to create  
qemu-window

 Such a failed domain has no status and the cpu time isn't gained as below.

 #xm list vm1
 Name                            ID Mem(MiB) VCPUs State   Time(s)
 vm1                             10      512     1 ------      0.0

Version-Release number of selected component (if applicable):
 RHEL5 Beta2 Milestone 8
 
How reproducible:
 Occasionally
 42times in 618times of creating.

Steps to Reproduce:
1.xm create <config>
2.xm shutdown <domain>
3.Repeat 1-2
  
Actual results:
 Occasionally qemu-window was not started.

Expected results:
 VTI domain is always created normally with qemu-window.

Additional info:
 Applied aron's patch and selinux-policy-2.4.2-9.
 But the same issue occured.

Comment 1 Watanabe Takehiko 2006-11-29 02:02:51 UTC
Created attachment 142353 [details]
log files related with xen

Comment 2 Watanabe Takehiko 2006-11-29 02:07:21 UTC
Created attachment 142354 [details]
the sysreport when the issue occured

Comment 5 Steven Rostedt 2007-07-31 16:00:51 UTC
I tested this with the following script:

  while : ; do
     xm create rhel5_x86_64;
     read f;
     xm destroy $x;
     let x=$x+1;
   done

The read was to let me make sure the window was created before destroying the
domain. I ran it 700 times, and the window was created each time.

Also note that the title of this BZ is misleading. The bug is not with the
status not appearing, but the bug is that the qemu-window was not created.


Comment 6 Chris Lalancette 2008-03-27 04:47:10 UTC
It looks like this one is actually fixed, and the IT was closed long ago.  I
think it just wasn't in the system to go ON_QA -> CLOSED.  I'll just close it as
CURRENTRELEASE for now.

Chris Lalancette


Note You need to log in before you can comment on or make changes to this bug.