Bug 21764 - power cycle during detection causes loss of hw info
power cycle during detection causes loss of hw info
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: kudzu (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-05 16:18 EST by Ed McKenzie
Modified: 2014-03-16 22:17 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-05 16:22:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed McKenzie 2000-12-05 16:18:15 EST
Power cycling during hardware detection on bootup causes kudzu to lose its
stored config settings and redetect all hardware as 'newly installed' on
the next boot. This happens on both ext2 and ext3 filesystems.

Whether this behavior is correct, I'm not sure, but I'm inclined to not
think so.
Comment 1 Bill Nottingham 2000-12-05 16:21:58 EST
The resulting filesystem check *probably* removed /etc/sysconfig/hwconf,
in which case there's not much that can be done.
Comment 2 Ed McKenzie 2000-12-05 17:35:33 EST
This first happened on the latest ext3fs; I later reproduced it on ext2. Do you
suppose a journal replay would result in the same recovered fs state as an
e2fsck run? I'd tend to think they're not *quite* the same, since journaling can
repair things that e2fsck cannot.

In any case, I guess redetecting everything is better than trying to recover
possibly stale configuration data.

Note You need to log in before you can comment on or make changes to this bug.