Bug 217676 - [PATCH] RHEL5-B2:ipmitool fru print displays error for physical fru devices
Summary: [PATCH] RHEL5-B2:ipmitool fru print displays error for physical fru devices
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: OpenIPMI (Show other bugs)
(Show other bugs)
Version: 5.0
Hardware: x86_64 Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Phil Knirsch
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks: 200812
TreeView+ depends on / blocked
 
Reported: 2006-11-29 11:03 UTC by Raghavendra Biligiri
Modified: 2015-03-05 01:18 UTC (History)
3 users (show)

Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-11 02:07:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for fixing this issue (447 bytes, patch)
2006-11-29 11:03 UTC, Raghavendra Biligiri
no flags Details | Diff

Description Raghavendra Biligiri 2006-11-29 11:03:37 UTC
Description of problem:
On RHEL5-B2(kernel-2.6.18-1.2747.el5), when displaying the system FRU devices 
using 'ipmitool fru print', an error message will be displayed when attempting 
to display Physical FRU devices.  Physical FRU devices do not use the FRU 
interface and should not be displayed.

Version-Release number of selected component (if applicable):
OpenIPMI-2.0.6
ipmitool-1.8.8

How reproducible:


Steps to Reproduce:
1.Install RHEL5-B2 (kernel-2.6.18-1.2747.el5)
2.Execute 'ipmitool fru print'
3.
  
Actual results:

FRU Device Description : Builtin FRU Device (ID 0)
 Board Mfg             : DELL
 Board Product         : FRU16K,DELL P/N               
 Board Serial          : CN7170352F0470
 Board Part Number     : 0G7255A01

FRU Device Description : PROC (ID 160)
 Device not present (Parameter out of range)


Expected results:

FRU Device Description : Builtin FRU Device (ID 0)
 Board Mfg             : DELL
 Board Product         : FRU16K,DELL P/N               
 Board Serial          : CN7170352F0470
 Board Part Number     : 0G7255A01

Additional info:
Patch that fixes this issue is attached.

Comment 1 Raghavendra Biligiri 2006-11-29 11:03:37 UTC
Created attachment 142375 [details]
Patch for fixing this issue

Comment 2 Samuel Benjamin 2006-12-06 19:50:34 UTC
Dell needs this fix for ipmtool in 5.0 - patch included.

Comment 3 RHEL Product and Program Management 2006-12-06 20:00:28 UTC
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.

Comment 7 Phil Knirsch 2006-12-13 13:54:57 UTC
OpenIPMI-2.0.6-5.el5.3 and newer contain the fix.

Read ya, Phil

Comment 8 Raghavendra Biligiri 2006-12-15 13:08:32 UTC
Issue is not reproducible with OpenIPMI-2.0.6-5.el5.3

Comment 9 Amit Bhutani 2006-12-20 11:26:58 UTC
Since OpenIPMI-2.0.6-5.el5.3 or higher is not available in a Snapshot yet, we
should keep this open in the MODIFIED state until a later snapshot is made
available to Dell.


Comment 10 Amit Bhutani 2007-01-10 18:30:48 UTC
OpenIPMI-2.0.6-5.el5.3 has been included in RC Snapshot 6. Marking the issue as
VERIFIED. RH- Please close. Thanks.


Note You need to log in before you can comment on or make changes to this bug.