Bug 217676 - [PATCH] RHEL5-B2:ipmitool fru print displays error for physical fru devices
[PATCH] RHEL5-B2:ipmitool fru print displays error for physical fru devices
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: OpenIPMI (Show other bugs)
5.0
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Phil Knirsch
:
Depends On:
Blocks: 200812
  Show dependency treegraph
 
Reported: 2006-11-29 06:03 EST by Raghavendra Biligiri
Modified: 2015-03-04 20:18 EST (History)
3 users (show)

See Also:
Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-10 21:07:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch for fixing this issue (447 bytes, patch)
2006-11-29 06:03 EST, Raghavendra Biligiri
no flags Details | Diff

  None (edit)
Description Raghavendra Biligiri 2006-11-29 06:03:37 EST
Description of problem:
On RHEL5-B2(kernel-2.6.18-1.2747.el5), when displaying the system FRU devices 
using 'ipmitool fru print', an error message will be displayed when attempting 
to display Physical FRU devices.  Physical FRU devices do not use the FRU 
interface and should not be displayed.

Version-Release number of selected component (if applicable):
OpenIPMI-2.0.6
ipmitool-1.8.8

How reproducible:


Steps to Reproduce:
1.Install RHEL5-B2 (kernel-2.6.18-1.2747.el5)
2.Execute 'ipmitool fru print'
3.
  
Actual results:

FRU Device Description : Builtin FRU Device (ID 0)
 Board Mfg             : DELL
 Board Product         : FRU16K,DELL P/N               
 Board Serial          : CN7170352F0470
 Board Part Number     : 0G7255A01

FRU Device Description : PROC (ID 160)
 Device not present (Parameter out of range)


Expected results:

FRU Device Description : Builtin FRU Device (ID 0)
 Board Mfg             : DELL
 Board Product         : FRU16K,DELL P/N               
 Board Serial          : CN7170352F0470
 Board Part Number     : 0G7255A01

Additional info:
Patch that fixes this issue is attached.
Comment 1 Raghavendra Biligiri 2006-11-29 06:03:37 EST
Created attachment 142375 [details]
Patch for fixing this issue
Comment 2 Samuel Benjamin 2006-12-06 14:50:34 EST
Dell needs this fix for ipmtool in 5.0 - patch included.
Comment 3 RHEL Product and Program Management 2006-12-06 15:00:28 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux major release.  Product Management has requested further
review of this request by Red Hat Engineering, for potential inclusion in a Red
Hat Enterprise Linux Major release.  This request is not yet committed for
inclusion.
Comment 7 Phil Knirsch 2006-12-13 08:54:57 EST
OpenIPMI-2.0.6-5.el5.3 and newer contain the fix.

Read ya, Phil
Comment 8 Raghavendra Biligiri 2006-12-15 08:08:32 EST
Issue is not reproducible with OpenIPMI-2.0.6-5.el5.3
Comment 9 Amit Bhutani 2006-12-20 06:26:58 EST
Since OpenIPMI-2.0.6-5.el5.3 or higher is not available in a Snapshot yet, we
should keep this open in the MODIFIED state until a later snapshot is made
available to Dell.
Comment 10 Amit Bhutani 2007-01-10 13:30:48 EST
OpenIPMI-2.0.6-5.el5.3 has been included in RC Snapshot 6. Marking the issue as
VERIFIED. RH- Please close. Thanks.

Note You need to log in before you can comment on or make changes to this bug.