Bug 217697 - update request to Banshee 0.11.2
update request to Banshee 0.11.2
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: banshee (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Christopher Aillon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-29 09:27 EST by David Nielsen
Modified: 2007-11-30 17:11 EST (History)
4 users (show)

See Also:
Fixed In Version: banshee-0.11.5-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-03-04 13:17:51 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Nielsen 2006-11-29 09:27:24 EST
Description of problem:
The Banshee 0.11.x series has been out for a while now and it solves a lot of
crasher bugs as well as opens for new functionality like podcast support. An
update would thus be great appriciated.
Comment 1 Thomas J. Baker 2006-12-19 10:27:39 EST
Seconded. If it requires mono 1.2.2 which is only in devel, an update there
would be good enough for me. I can rebuild the rpms for fc6. I got usbstick mp3
players for my 3 and 5 year old boys for xmas and it looks like banshee provides
auto transcoding for my ogg collection to mp3 for them.
Comment 2 David Nielsen 2006-12-19 10:41:22 EST
I tried to hack up a set of SPEC files but upstream does not love the joys of
multilib systems and as such is prone to hardcode things like /usr/lib.

Regardless if you want to use ipods with Banshee you need the updated
libipoddevice and that does not compile against sg3_utils since that hardcodes
such data as well. That is filed as #198223. Banshee is a bit of a pain to
package but a joy to use.
Comment 3 Christopher Aillon 2006-12-19 10:53:32 EST
If you even look at the banshee-shipped dependencies libipoddevice and
ipod-sharp you might be able to tell I'm working on this.
Comment 4 Thomas J. Baker 2006-12-19 10:59:54 EST
I did see an ipod-sharp update a while back which gave me hope.
Comment 5 Thomas J. Baker 2007-01-31 09:44:51 EST
Using the banshee 0.10.12 src rpm as a base, I've got banshee 2053 svn checkout
working for i386. I ported the two patches from 10.12 to 11.5 and built it under
mock for rawhide but if you install ipod-sharp and libipoddevice from rawhide
along with this new banshee, it all seems to work fine for fc6.

http://wintermute.sr.unh.edu/banshee/banshee-0.11.5.2053-1.fc7.src.rpm
http://wintermute.sr.unh.edu/banshee/banshee-0.11.5.2053-1.fc7.i386.rpm
http://wintermute.sr.unh.edu/banshee/banshee-debuginfo-0.11.5.2053-1.fc7.i386.rpm

I don't have an x86-64 system to build it on but if the patches worked for 10.12
they may work for 11.5. The 2053 svn checkout is post 11.5 and includes a patch
that fixes a crash when trying to get properties of an ipod. I still don't have
any luck syncing my ipod shuffles with any version of banshee but I think that's
a banshee problem and not a fedora one. Additions to the shuffle are not
recognized but appear fine in banshee.

Note You need to log in before you can comment on or make changes to this bug.