Bug 217699 - RFE: LaTeX support fixed in upstream SVN
RFE: LaTeX support fixed in upstream SVN
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: inkscape (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-29 09:33 EST by Ed Hill
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-06 06:46:20 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ed Hill 2006-11-29 09:33:45 EST
Description of problem:
LaTeX support (Effects -> Render -> LaTeX formula) is broken in inkscape
0.44.1-1.fc6 but has been fixed in the upstream svn.  Please consider 
patching or upgrading just two files (described below) to fix this issue.

Version-Release number of selected component (if applicable):
0.44.1-1.fc6

How reproducible:
100%

The two upgraded files are in the inkscape subversion repo at:

http://inkscape.svn.sourceforge.net/viewvc/inkscape/inkscape/trunk/share/extensions/eqtexsvg.py
http://inkscape.svn.sourceforge.net/viewvc/inkscape/inkscape/trunk/share/extensions/inkex.py

and if you copy them to their respective locations in the file system:

/usr/share/inkscape/extensions/eqtexsvg.py
/usr/share/inkscape/extensions/inkex.py

then the LaTeX support will work nicely for many LaTeX inputs such as:

\begin{equation*}\lim_{n \to \infty}\sum_{k=1}^n \frac{1}{k^2}=
\frac{\pi^2}{6}\end{equation*}

[ Please note that the default equation provided by inkscape does not
  work since it is a "math mode" example that needs to be wrapped in
  either "$...$" or "\begin{equation*}...\end{equation*}" syntax. ]
Comment 1 Ed Hill 2006-11-29 09:51:37 EST
There is a thread at:

http://www.archivesat.com/Inkscape_developers/thread2153889.htm

that describes the above.  In it one of the inkscape developers mentions 
that they would appreciate broader testing of the LaTeX bits.  FWIW it 
works nicely on my FC6 (i386) system -- and does indeed give better 
error messages when fed incorrect LaTeX syntax.
Comment 2 Denis Leroy 2006-12-02 09:57:56 EST
Thanks for the heads up. I also need to fix another problem with postscript
import so I'll push an update as soons as that's done.
Comment 3 Denis Leroy 2006-12-06 06:46:20 EST
Fixed and built, should be available at the next Fedora Extras push. Please
verify the fix if you can, and reopen if it is not. Thanks!
Comment 4 Ed Hill 2006-12-08 09:35:13 EST
Hi Denis, I've "yum update"-ed inkscape and the LaTeX bits work nicely.

Thank you for the speedy fix !!!

Note You need to log in before you can comment on or make changes to this bug.