Bug 217700 - Xen HV is unable to load FC6 updates kernel as HVM guest
Xen HV is unable to load FC6 updates kernel as HVM guest
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: xen (Show other bugs)
5.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steven Rostedt
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-29 09:40 EST by Juan Quintela
Modified: 2008-03-27 00:49 EDT (History)
3 users (show)

See Also:
Fixed In Version: 5.1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-27 00:49:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
failed boot with 2.6.18-1.2849.fc6 (3.94 KB, text/plain)
2006-11-29 09:40 EST, Juan Quintela
no flags Details

  None (edit)
Description Juan Quintela 2006-11-29 09:40:43 EST
Description of problem:

Xen HV fails to load FC6 HVM guest with updates kernel for FC6

Version-Release number of selected component (if applicable):

kernel-xen-2.6.18-1.2747.el5
xen-libs-3.0.3-8.el5
xen-3.0.3-8.el5

(If I updated to xen-3.0.3-9.el5 from nightly, same problem occurs)

How reproducible:

Allways happens here.


Steps to Reproduce:
1. Install a FC6 HVM guest
2. Boot it, see that everything works
3. yum upgrade kernel on the FC6 guest
  
Actual results:

Kernel don't boot, stoops at the middle of the boot.
New kernel is: kernel-2.6.18-1.2849.fc6

attached log of failed boot.

Expected results:

Kernel booting as with the previous kernel.
old kernel is: kernel-2.6.18-1.2798.fc6


Additional info:

I got the same problems on x86_64.  In two different machines (but both of them
Core 2 based).
Comment 1 Juan Quintela 2006-11-29 09:40:43 EST
Created attachment 142381 [details]
failed boot with 2.6.18-1.2849.fc6
Comment 2 Daniel Berrange 2006-12-01 12:17:47 EST
I can reproduce this on a i686  Intel Core Duo too.

Comment 3 Jarod Wilson 2006-12-07 10:29:30 EST
As mentioned on at least one internal mailing list, this is due to the new
auto-apic patch the FC6 updates kernel is carrying. It also breaks systems
running LinuxBOIS (no DMI tables whatsoever) and a few boxes with wonky DMI
tables -- see bug 215154 for additional info.
Comment 5 Steven Rostedt 2007-08-01 21:35:40 EDT
I installed a FC6, and the kernel boots. But of course this is kernel-2798.
Comment 6 Chris Lalancette 2008-03-27 00:49:28 EDT
Given that this one was for FC6 guests, and rostedt seems to have changed it to
MODIFIED, going to close it out as CURRENTRELEASE.

Chris Lalancette

Note You need to log in before you can comment on or make changes to this bug.