Bug 217707 - apt-rpm segfault on my AMD Duron machine
apt-rpm segfault on my AMD Duron machine
Status: CLOSED DUPLICATE of bug 211254
Product: Fedora
Classification: Fedora
Component: apt (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-29 10:11 EST by Jérôme Benoit
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-29 14:32:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
apt-get update core dump (2.98 MB, application/octet-stream)
2006-11-29 10:16 EST, Jérôme Benoit
no flags Details

  None (edit)
Description Jérôme Benoit 2006-11-29 10:11:31 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; fr; rv:1.8.0.8) Gecko/20061107 Fedora/1.5.0.8-1.fc6 Firefox/1.5.0.8

Description of problem:
The latest apt update from extras segfault during on apt-get update, juste after repomd.xml, primary.xml et filelists.xml download. Surely while opening and starting parse the files.

Version-Release number of selected component (if applicable):
apt-0.5.15lorg3.2-8.fc6

How reproducible:
Always


Steps to Reproduce:
1. Just run apt-get update on my AMD Duron box
2.
3.

Actual Results:
strace outpout :
mmap2(NULL, 6608416, PROT_READ, MAP_SHARED, 6, 0) = 0xb7438000
stat64("/etc/apt/rpmpriorities", {st_mode=S_IFREG|0644, st_size=379, ...}) = 0
stat64("/var/lib/apt/lists/download.fedora.redhat.com_pub_fedora_linux_core_6_i386_os_repodata_primary.xml", {st_mode=S_IFREG|0644, st_size=5799313, ...}) = 0
--- SIGSEGV (Segmentation fault) @ 0 (0) ---
+++ killed by SIGSEGV (core dumped) +++

Expected Results:


Additional info:
Comment 1 Jérôme Benoit 2006-11-29 10:16:14 EST
Created attachment 142383 [details]
apt-get update core dump
Comment 2 Jérôme Benoit 2006-11-29 10:23:57 EST
The same core dump is wait for approval on apt-rpm.org mailing list.

The same segfault happening after an apt-get clean all.

/proc/cpuinfo output : 

processor       : 0
vendor_id       : AuthenticAMD
cpu family      : 6
model           : 3
model name      : AMD Duron(tm) Processor
stepping        : 1
cpu MHz         : 807.200
cache size      : 64 KB
fdiv_bug        : no
hlt_bug         : no
f00f_bug        : no
coma_bug        : no
fpu             : yes
fpu_exception   : yes
cpuid level     : 1
wp              : yes
flags           : fpu vme de pse tsc msr pae mce cx8 mtrr pge mca cmov pat pse36
mmx fxsr syscall mmxext 3dnowext 3dnow up
bogomips        : 1615.67

kernel-2.6.18-1.2849.fc6 for i686 installed.

Hope this help.
Comment 3 Axel Thimm 2006-11-29 14:32:06 EST

*** This bug has been marked as a duplicate of 211254 ***

Note You need to log in before you can comment on or make changes to this bug.