Bug 217750 - ncurses package fails to install
ncurses package fails to install
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: ncurses (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Miroslav Lichvar
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-29 14:04 EST by Michal Jaegermann
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-11-30 07:18:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2006-11-29 14:04:32 EST
Description of problem:

When attempting an update to ncurses-5.5-25.20060715.fc7 something
of that sort shows up:

  Updating  : ncurses                      ##################### [ 18/162]
error: unpacking of archive failed on file /lib/terminfo/v/vt220;456dcf2f: cpio:
link

The problem is that in a new package /lib/terminfo/v/vt220 turns out
to be a hard link to /usr/share/terminfo/v/vt200 and this fails if
/lib/terminfo/v/ and /usr/share/terminfo/v/ happen _not_ to share
a file system.

Results are:
  - 'rpm -q ncurses' reports only an old version installed
  - on a disk there is a mess of old and new files making
    'rpm -V ncurses' quite unhappy
  - /usr/share/terminfo/v/vt220 ends up as broken link to nowhere
  - with now default 'keepcache=0', if somebody is crazy enough to
    use it, the whole cache is dumped making hard to diagnose what
    happened.

Version-Release number of selected component (if applicable):
ncurses-5.5-25.20060715.fc7

How reproducible:
always with /lib and /usr/share on different file systems
Comment 1 Michal Jaegermann 2006-11-29 14:14:58 EST
Closer look reveals that also /lib/terminfo/v/vt100 is a hard link
to /usr/share/terminfo/v/vt100-am.
Comment 2 Miroslav Lichvar 2006-11-30 07:18:08 EST
Thanks for the report. Should be fixed in ncurses-5.5-26.20060715.fc7.

Note You need to log in before you can comment on or make changes to this bug.