Bug 217772 - Gamin support doesn't work
Gamin support doesn't work
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: Thunar (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-29 15:57 EST by Michael Cronenworth
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-01 09:58:26 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Cronenworth 2006-11-29 15:57:56 EST
Description of problem: Auto-refresh with gamin doesn't work unless you rebuild
the Thunar package.


Version-Release number of selected component (if applicable): 0.5.0rc2


How reproducible: Everytime


Steps to Reproduce:
1. Open Thunar, open Terminal
2. $ touch test
3. No "test" file is shown in Thunar
  
Actual results: No "test" file is shown in Thunar

Expected results: "test" file should appear in Thunar


Additional info: After rebuilding the Thunar package I was immediately able to
see the "test" file when I touched it. I can also see other file operations
happen immediately.

Sounds like something didn't get built right with gamin somehow?
Comment 1 Kevin Fenzi 2006-11-29 16:44:31 EST
Odd. It works fine for me here... Thunar was built with gamin support: 
...
checking for gamin >= 0.1.0... 0.1.7
checking LIBFAM_CFLAGS... -I/usr/include/fam  
checking LIBFAM_LIBS... -lgamin-1  
...

What is the output of 'rpm -q Thunar' there?

Comment 2 Michael Cronenworth 2006-11-29 17:36:37 EST
Thunar-0.5.0-0.1.rc2

I'm not doubting the official package was built with gamin support, but for some
reason it isn't working when I use the official package. It affects two systems
I use XFCE on. One is a development machine(32-bit), and another is a desktop
machine (64-bit).

I finally got fed up that it wasn't refreshing automatically I rebuilt it
manually and it's working fine now. Per your SPEC file, you can't even build
Thunar unless you have gamin-devel installed, so I'm as puzzled as you are on this.
Comment 3 Michael Cronenworth 2006-11-29 18:16:57 EST
Forget the desktop machine, it works fine. For some reason it only affected my
32-bit machine. Unsure if the reinstall of the Thunar did something... so you
might put this bug on the back burner for a few weeks and if you don't hear from
me it's probably nothing to worry about.
Comment 4 Kevin Fenzi 2006-11-29 18:56:45 EST
So both machines are now working? Or the 32bit devel machine is still not working?
Comment 5 Michael Cronenworth 2006-12-01 09:58:26 EST
I reinstalled the official Thunar package and it seems to be OK. Reinstalling
seemed to have fixed it.

Note You need to log in before you can comment on or make changes to this bug.