Bug 2178178 - emoji input entirely broken
Summary: emoji input entirely broken
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: ibus
Version: 38
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: fujiwara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: F38FinalFreezeException
TreeView+ depends on / blocked
 
Reported: 2023-03-14 13:13 UTC by Akira TAGOH
Modified: 2023-03-20 00:16 UTC (History)
4 users (show)

Fixed In Version: ibus-1.5.28-3.fc38
Doc Type: If docs needed, set a value
Doc Text:
Clone Of:
Environment:
Last Closed: 2023-03-20 00:16:16 UTC
Type: Bug
Embargoed:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
GNOME Gitlab GNOME gnome-shell issues 6518 0 None opened IBus emojier cannot get focus-in event in Wayland 2023-03-17 14:08:39 UTC
Github ibus ibus issues 2476 0 None closed Issue with ibus_serializable_deserialize_object 2023-03-17 14:08:39 UTC
Red Hat Issue Tracker FC-787 0 None None None 2023-03-17 14:14:49 UTC

Description Akira TAGOH 2023-03-14 13:13:28 UTC
Description of problem:
The emoji input doesn't work as mensioned at https://fedoraproject.org/wiki/QA:Testcase_ibus_emojier

Version-Release number of selected component (if applicable):
ibus-1.5.28-1.fc38.x86_64

How reproducible:
always

Steps to Reproduce:
1.press Super+period
2.type smile and space
3.or simply space once 'e' appears

Actual results:
No lookup window nor emoji at 2
'Unicodeの選択肢を開く' appears at the lookup window, and click it, apparently first entry from gettext PO is displayed instead of emoji.

Expected results:
emoji picker should works

Additional info:

Comment 1 Jens Petersen 2023-03-15 08:21:28 UTC
I can reproduce this

Comment 2 Jens Petersen 2023-03-15 08:25:12 UTC
Proposing as an freeze exception I think this actually qualifies as a Blocker.

Comment 3 fujiwara 2023-03-17 08:03:20 UTC
I cannot reproduce your issue in the installed Fedora 38.

# rpm -qf /etc/fedora-release 
fedora-release-common-38-0.30.noarch

Comment 4 fujiwara 2023-03-17 09:15:43 UTC
Seems this problem is not reproduced when I build libibus.so by myself but can be with the koji libibus.so.
Maybe a debug info changes the timing.

Comment 5 fujiwara 2023-03-17 14:08:39 UTC
There are two issues in GNOME Wayland
One is the build optimization causes some emoji data is not initialized.
Another is IBus Emojier cannot get focus-in event and output the selected char.

The former issue is reported in https://github.com/ibus/ibus/issues/2476 and fixed in IBus upstream.

The later issue is a known gnome-shell regression and provided a patch in https://gitlab.gnome.org/GNOME/gnome-shell/-/issues/6518

I added a workaround for the later issue but it does not fix the issue completely.


A left issue is that Super-Period does not work with GTK4 applications in GNOME Xorg but it would be another issue and the different priority.

Comment 6 Fedora Update System 2023-03-17 14:43:27 UTC
FEDORA-2023-e0df9e598e has been submitted as an update to Fedora 38. https://bodhi.fedoraproject.org/updates/FEDORA-2023-e0df9e598e

Comment 7 Fedora Update System 2023-03-18 05:12:54 UTC
FEDORA-2023-e0df9e598e has been pushed to the Fedora 38 testing repository.

You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2023-e0df9e598e

See also https://fedoraproject.org/wiki/QA:Updates_Testing for more information on how to test updates.

Comment 8 Fedora Update System 2023-03-20 00:16:16 UTC
FEDORA-2023-e0df9e598e has been pushed to the Fedora 38 stable repository.
If problem still persists, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.