Bug 217832 - Echo icon theme is not present in KDE control center
Echo icon theme is not present in KDE control center
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: echo-icon-theme (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: David Zeuthen
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-30 03:53 EST by Julian Sikorski
Modified: 2013-03-05 22:48 EST (History)
8 users (show)

See Also:
Fixed In Version: 0.3-3.git.fc8
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-02-19 08:58:04 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot on kde (195.15 KB, image/png)
2007-02-04 12:50 EST, Chitlesh GOORAH
no flags Details
patch (1.96 KB, patch)
2007-02-04 12:51 EST, Chitlesh GOORAH
no flags Details | Diff

  None (edit)
Description Julian Sikorski 2006-11-30 03:53:40 EST
Description of problem:
I have installed echo-icon-theme package from rawhide under fc6. I can select
the theme for gnome, but it is not present in KDE control center

Version-Release number of selected component (if applicable):
echo-icon-theme-0.1-6.fc7

How reproducible:
always

Steps to Reproduce:
1. su
2. yum --enablerepo=development install echo-icon-theme
  
Actual results:
There is no Echo theme in KDE control center.

Expected results:
It should be there, just the same way as tango is.
Comment 1 Matthias Clasen 2006-11-30 09:30:49 EST
KDE problem, I would say.
Comment 2 Julian Sikorski 2006-11-30 14:04:00 EST
You think so? Then, this may be useful as well:
[jsikorski@fcdesktop ~]$ kde-config --version
Qt: 3.3.7
KDE: 3.5.5-0.2.fc6 Fedora-Core
kde-config: 1.0
[jsikorski@fcdesktop ~]$
Comment 3 Mark 2006-12-17 10:38:52 EST
[root@Marks-PC Echo]# kde-config --version
Qt: 3.3.7
KDE: 3.5.5-0.2.fc6 Fedora-Core
kde-config: 1.0
[root@Marks-PC Echo]#     

That`s what i have and i have the exact same problem.. perhaps the index.theme
file needs to be recreated? and where are the higher quality icons? because now
the max size i can find is 48x48
Comment 4 Chitlesh GOORAH 2007-02-04 12:48:55 EST
I've a patch to fix the presence of echo theme on kcontrol. Which I'll upload soon.

However to my point of view, there are lots of things to fix and improve in the
icon set so that we can make it the default Icon set for Fedora KDE spin.

A screenshot will also be attached.
Comment 5 Chitlesh GOORAH 2007-02-04 12:50:27 EST
Created attachment 147310 [details]
screenshot on kde
Comment 6 Chitlesh GOORAH 2007-02-04 12:51:22 EST
Created attachment 147311 [details]
patch
Comment 7 Rex Dieter 2007-02-05 09:25:19 EST
Yup, MUSTFIX, before it can be considered for F7/kde's default icon set.
Comment 8 Matthias Clasen 2007-02-05 12:21:07 EST
Nope, randomly changing categories is a nonstarter
Comment 9 Rex Dieter 2007-02-05 13:34:39 EST
Agreed, Chitlesh, you need to provide justification(s) for the patch.
Comment 10 Chitlesh GOORAH 2007-02-05 14:13:20 EST
The original index.theme uses the following Context=
Context=emotions
Context=emblems
Context=categories
Context=status
Context=actions
Context=places
Context=mimetypes
Context=devices
Context=apps

Theses aren't according the freedesktop specification.
kcontrol icon module doesn't seem to see the entry in index.theme unless it's a
context it recognises

http://standards.freedesktop.org/icon-theme-spec/icon-theme-spec-latest.html#context

I admit my patch having only Context=Actions isn't the best solution. But at
least to pinpoint what could be the problem.
Comment 11 Luya Tshimbalanga 2007-02-07 15:33:40 EST
I also think the bug is related to KDE because of the lack of 24x24 icons on
most themes. Perhaps investigating that issue will be a good starting point.
Comment 12 Chitlesh GOORAH 2007-02-07 18:44:11 EST
Well it is not really a problem of 22x22 or 24x24. I was wrong. Sounds like KDE
dislikes symbolic links.
take for example if you
- delete 24x24/actions/up.png (which is a symbolic link)
- copy and paste 24x24/actions/go-up.png as up.png
- create a tarball
- install the tarball via kcontrol

you will see the up.png on your konqueror.
So the kde bug (for the missing icons in the toolbar) is mostly related to
symbolic links and not to missing 22x22.

As David Zeuthen cares for space, we have to re-think how symbolic links should
be made.
Comment 13 Red Hat Bugzilla 2007-03-27 00:50:09 EDT
User dfong@redhat.com's account has been closed
Comment 14 Chitlesh GOORAH 2007-03-27 13:16:53 EDT
??
What happened to diana's account ?
Comment 15 Matthias Clasen 2007-03-31 16:40:52 EDT
It has been closed, because she left Red Hat.
Comment 16 Rex Dieter 2007-04-03 17:01:21 EDT
Any timeline in addressing this?  
If not soon, we'll have to omit it from the kde spin/livecd, since it simply
does not work in kde as-is.
Comment 17 Matthias Clasen 2007-05-15 11:25:45 EDT
Nobody from the KDE side has come forward to explain 

a) what exactly is the problem that KDE has with echo
b) what changes are necessary to fix this

If KDE does not handle symlinks in icon themes correctly, as comment 12 seems to
indicate, this really cannot be fixed in the echo-icon-theme.
Comment 18 Jakub 'Livio' Rusinek 2007-05-21 07:24:38 EDT
KDE or GNOME doesn't applied to FreeDesktop.org icon naming standard, so
iconsset for KDE willn't work in GNOME and vice versa.
Comment 19 Rex Dieter 2007-05-21 14:39:52 EDT
Seems there are a few distinct issues here:
1.  icon categories (see comment #8, comment #10)
2.  symlinks (see comment #12)
3.  kde's use/non-use of 22x22 vs. 24x24 sized icons.

For (1), seems to be a simple case of applying the patch provided to make echo
conform to icon-theme-spec.

The latter ones, seem to be open (kde-specific) problems.
Comment 20 Matthias Clasen 2007-05-21 15:21:45 EDT
Regarding the first point, there is currently some conflicting information, if
you compare the icon theme spec and the icon naming spec. I think this needs to
be clarified on xdg-list, I'll send a mail.

Tango also uses categories from the icon naming spec. Does Tango work with kde ?
Comment 21 Rex Dieter 2007-05-21 15:29:47 EDT
yes, tango works (seems to for me anyway)

fwiw,
$ rpm -q tango-icon-theme
tango-icon-theme-0.7.2-5.fc6

$ grep '^Context=' /usr/share/icons/Tango/index.theme  | sort |  uniq
Context=Actions
Context=Applications
Context=Categories
Context=Devices
Context=Emblems
Context=Emotes
Context=MimeTypes
Context=Places
Context=Status

So, it too includes some extra contexts referenced only in the naming-spec (not
theme-spec), but I think these have been patched into kde.  See
http://bugs.kde.org/120562
and
http://tango.freedesktop.org/Installation#Patches_to_KDE

Comment 22 Rex Dieter 2007-05-21 15:36:32 EDT
Looks to me that the patch as-is isn't correct, it's mostly just a matter of 
capitalizing the context targets.
Comment 23 Matthias Clasen 2007-05-21 22:08:05 EDT
Indeed, seems Johns script to harvest the icons from the wiki has some
shortcomings. I'm correcting the contexts for now, but there are more problems,
e.g. I see 16x16/mimes/x-office-calendarS-.png, which is probably supposed to be
16x16/mimetypes/x-office-calendar.png.

Please let me know if echo-icon-theme-0.2-3.20070419wiki.fc8 works better with
kde, it has the contexts fixed.
Comment 24 Luya Tshimbalanga 2007-08-27 02:37:37 EDT
Closing bug as the issue is solved. Please reopen if similar problem occurs.
Comment 25 Rex Dieter 2007-08-27 09:42:06 EDT
Ugh, still no workie,

$ rpm -q echo-icon-theme
echo-icon-theme-0.2-2.20070419wiki.fc7.noarch
Comment 26 David Zeuthen 2007-10-09 11:10:27 EDT
We don't use Echo as the default theme so moving off the target list.
Comment 27 Rex Dieter 2008-02-19 08:58:04 EST
Confirmed that echo-icon-theme-0.3-3.git.fc8 works (better, anyway).

Note You need to log in before you can comment on or make changes to this bug.