Bug 217854 - tomcat will not uninstall
Summary: tomcat will not uninstall
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: tomcat5   
(Show other bugs)
Version: 6
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Vivek Lakshmanan
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-11-30 13:38 UTC by Denis Leroy
Modified: 2008-01-05 12:56 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-05 12:56:51 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Denis Leroy 2006-11-30 13:38:15 UTC
Despite starting from a clean FC-6 setup (with no problems reported by
package-cleanup --problems) and only running yum-removes to get rid of the java
stuff, I got myself in a situation where I can't uninstall tomcat5 because of a
scriplet error :

sudo rpm -e tomcat5
find: /var/lib/tomcat5/common/endorsed: No such file or directory
/var/tmp/rpm-tmp.82114: line 1: /usr/bin/rebuild-gcj-db: No such file or directory
error: %postun(tomcat5-5.5.17-6jpp.2.i386) scriptlet failed, exit status 127


Please always use the '|| :' appendix in preun and postun scriptlets, to make
sure one can always remove packages, even if one got into incoherent/broken RPM
setup by accident or because of a bug.

Thanks!

Comment 1 Denis Leroy 2006-11-30 13:39:08 UTC
Reassigning to tomcat5.


Comment 2 Devrim GUNDUZ 2008-01-05 12:56:51 UTC
Cannot reproduce this error in the latest release, so closing this bug.


Note You need to log in before you can comment on or make changes to this bug.