Bug 217875 - cvs-import script is unable to create new modules
cvs-import script is unable to create new modules
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: 915resolution (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-30 10:51 EST by Neil Horman
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-04 15:06:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to fix cvs-import script (794 bytes, patch)
2006-11-30 10:51 EST, Neil Horman
no flags Details | Diff

  None (edit)
Description Neil Horman 2006-11-30 10:51:32 EST
Description of problem:
cvs-import.sh script is unable to create new modules

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1.import a new package to fedora extras
2.
3.
  
Actual results:
if the module doesn't yet exist in cvs, the import will fail

Expected results:
import should create the new module before checking it out.

Additional info:

This is occuring because the cvs-import.sh script adds the name of the module
being imported to the modules file, and then immediately greps for the name of
the module in that file as s test to see if it needs to create the module in
cvs.  Since we just added the name, this check will always erroneously decide
that the module already exists.

I haven't completely tested the attached patch yet, but I think something like
this should fix the issue
Comment 1 Neil Horman 2006-11-30 10:51:33 EST
Created attachment 142484 [details]
patch to fix cvs-import script
Comment 2 Jeremy Katz 2006-12-04 15:06:46 EST
No, it's not added to modules until after it sees it's not there already. 
Adding new packages is working for everyone else, so I think you're hitting
something else.  Please actually provide details of the failure you're seeing
and report them to the infrastructure ticketing system
(http://fedoraproject.org/wiki/Infrastructure/Tickets)

Note You need to log in before you can comment on or make changes to this bug.