Bug 217886 - Fix typo in the qla1280 reset
Fix typo in the qla1280 reset
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.5
All Linux
medium Severity medium
: ---
: ---
Assigned To: George Beshers
Brian Brock
:
Depends On:
Blocks: 229615 253738
  Show dependency treegraph
 
Reported: 2006-11-30 11:31 EST by George Beshers
Modified: 2007-11-30 17:07 EST (History)
5 users (show)

See Also:
Fixed In Version: RHBA-2007-0304
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-05-08 00:18:58 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Kernel changeset 40552 (1.07 KB, patch)
2006-11-30 11:31 EST, George Beshers
no flags Details | Diff

  None (edit)
Description George Beshers 2006-11-30 11:31:49 EST
Description of problem:
Customer reported that on his Altix with a ql12160 the performance of the
attached devices significantly drops after a bus reset had occured.
The problem is reproducible. Here the log of what has been done.


Version-Release number of selected component (if applicable):


How reproducible:
    Reliably.

Steps to Reproduce:
1. Reboot system
2. time dd if=/dev/sdb of=/dev/null bs=64k count=10000
     10000+0 records in
     10000+0 records out

     real    0m9.543s
     user    0m0.011s
     sys     0m0.577s

  As you see it takes about 10 seconds to complete the transfer.

3.  Now doing a bus reset.

    taclab26:~ # sg_reset -b /dev/sg1
    sg_reset: starting bus reset
    sg_reset: completed bus reset

Actual results:
    After the reset completed the transfer of the 10000 blocks takes about
    7.5 times longer as before.

    taclab26:~ # time dd if=/dev/sdb of=/dev/null bs=64k count=10000
    10000+0 records in
    10000+0 records out

    real    1m14.443s
    user    0m0.007s
    sys     0m0.595s
  
Expected results:
    faster :)

Additional info:
    Fix is changeset 40552 by Jes Sorensen
Comment 1 George Beshers 2006-11-30 11:31:49 EST
Created attachment 142488 [details]
Kernel changeset 40552
Comment 2 Linda Wang 2006-11-30 18:19:09 EST
I assume this is reported against rhel4.
Comment 3 RHEL Product and Program Management 2006-11-30 18:34:50 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 George Beshers 2006-11-30 22:36:06 EST
It should be applied to RHEL4.5 and RHEL5.0.
I suspect I should have created two BZs.
Comment 5 Linda Wang 2006-12-04 18:44:48 EST
Yes, please dup this to RHEL5 and resubmit the patch for RHEL5. 
Comment 6 George Beshers 2006-12-19 16:01:56 EST
Associating this with PV#957504 and added CC's.

I tried to change the product to Public Beta to
clarify that we are interested in RHEL 4.5, but
was told only the submitter or owner could do that
and since I am both it is therefore not allowed :-(.

Comment 7 Jay Turner 2007-01-02 08:48:57 EST
QE ack for RHEL4.5.
Comment 12 Tom Coughlan 2007-03-07 08:52:50 EST
Requesting an exception. 

There is a mis-placed closing paren in the qla1280 driver. 

-		if (qla1280_bus_reset(ha, bus == 0))
+		if (qla1280_bus_reset(ha, bus) == 0)

This results in reduced performance after a bus reset. The fix is clearly
correct, it has been upstream for quite a while, and it has been ACKed on
rhkernel-list. 

This driver is for old hardware that is not widely used by RHEL customers. The
bug has apparently been present for quite a while. So, we could defer this, but
that does not seem necessary in this case. 
Comment 15 Jason Baron 2007-03-21 13:01:31 EDT
committed in stream U5 build 51. A test kernel with this patch is available from
http://people.redhat.com/~jbaron/rhel4/
Comment 18 Red Hat Bugzilla 2007-05-08 00:18:58 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0304.html

Note You need to log in before you can comment on or make changes to this bug.