Bug 217890 - anaconda stage2: AttributeError: 'module' object has no attribute 'drivers'
anaconda stage2: AttributeError: 'module' object has no attribute 'drivers'
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
ia64 Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
: Regression
Depends On:
Blocks: fedora-ia64
  Show dependency treegraph
 
Reported: 2006-11-30 11:47 EST by Doug Chapman
Modified: 2008-05-01 11:39 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-18 11:22:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Doug Chapman 2006-11-30 11:47:18 EST
Description of problem:
Booting the rawhide installer on ia64 dies with the following.  This is a
kickstart install using serial console.  this is a regression since yesterday.


Traceback (most recent call last):
File "/usr/bin/anaconda", line 958, in ?
 instClass.setInstallData(anaconda)
File "/usr/lib/anaconda/kickstart.py", line 810, in setInstallData
self.ksparser.readKickstart(self.file)
File "/usr/lib/python2.4/site-packages/pykickstart/parser.py", line 1143, in
readKickstart
self.handleCommand(lineno, args)
File "/usr/lib/anaconda/kickstart.py", line 704, in handleCommand
self.handler.handlers[cmd](cmdArgs)
File "/usr/lib/anaconda/kickstart.py", line 604, in doXConfig
dict["startX"])
File "/usr/lib/anaconda/installclass.py", line 402, in configureX
self.setVideoCard(id, driver, videoRam)
File "/usr/lib/anaconda/installclass.py", line 377, in setVideoCard
db = rhpxl.videocard.drivers
AttributeError: 'module' object has no attribute 'drivers'
install exited abnormally [1/1]

Version-Release number of selected component (if applicable):
rawhide-20061130
anaconda-11.2.0.2-1


How reproducible:
100%

Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Doug Chapman 2006-11-30 13:05:25 EST
More info...

I only see this on kickstart installs.  Chris Lumens thought it might be avoided
by removing the xconfig line from my kickstart file however I still hit the same
traceback with that commented out.
Comment 2 Chris Lumens 2006-11-30 13:50:12 EST
Committed a fix.  Now that we don't have a list of valid drivers in rhpxl
anymore, anaconda just needs to trust what the user gives us.  I'll probably
rebuild anaconda tonight so you can test the fix tomorrow.
Comment 3 Doug Chapman 2007-01-04 12:39:43 EST
verified this long ago, sorry forgot to set the state to verified.

Note You need to log in before you can comment on or make changes to this bug.