Bug 217891 - Print does not work from the SELinux Troubleshoot Browser
Print does not work from the SELinux Troubleshoot Browser
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: setroubleshoot (Show other bugs)
6
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: John Dennis
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-30 11:47 EST by Gerard Fernandes
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-08-27 14:06:22 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
SELinux Troubleshooter output (98.03 KB, application/pdf)
2006-12-04 08:59 EST, Gerard Fernandes
no flags Details

  None (edit)
Description Gerard Fernandes 2006-11-30 11:47:28 EST
Description of problem: Can not print current selected SELinux error from the
SELinux Troubleshoot Browser window.


Version-Release number of selected component (if applicable):
setroubleshoot-1.7.1-1.fc6


How reproducible: Always


Steps to Reproduce:
1. Open the SETroubleshoot Browser (System/Administration/SELinux Troubleshooter)
2. Select a violation (if none are displayed, you may have to create a situation
that violates a current SE rule)
3. Select File/Print - the print dialog pops up.
4. Choose to print to file, choose your Home directory or desktop and set the
format to either PDF or PS
5. Print
  
Actual results: A blank PDF/PS file is created


Expected results: A PDF/PS file with the contents of the detail window for the
current selected SELinux error

Additional info: Print to PDF/PS used to work before. Its stopped working
recently after the last couple of updates. However, it was not possible to
cut/paste content from the generated PDF viewed in Evince to a text file. Note
that it is possible to cut and paste from a PDF generated from a OpenOffice
document, and viewed in Evince, to a text file.
Comment 1 Gerard Fernandes 2006-11-30 11:48:41 EST
Note that it is not possible to select-all and copy and paste from the SELinux
Troubleshooter browser window either.
Comment 2 Gerard Fernandes 2006-12-04 08:57:34 EST
Updated to setroubleshoot-1.8.3-2.fc6.
1. Printing to PDF works as expected. However, it is not possible to copy
content from the generated PDF. Try dragging the mouse to copy text OR using the
Edit/Select All option - note that text is selected in random blocks.
2. Copy and paste from the SETroubleshoot Browser window works using
Cntrl-C/Cntrl-V. However, it is not possible to copy content from the window
with the right mouse click.
Comment 3 Gerard Fernandes 2006-12-04 08:59:02 EST
Created attachment 142731 [details]
SELinux Troubleshooter output

Note that it is not possible to copy content from the generated PDF - either by
dragging the mouse over the text, or by selecting Edit/Select All.
Comment 4 John Dennis 2007-08-27 14:06:22 EDT
Closing. Printing does work (at least in current versions). Printing to PDF does
work and the text can be selected. Printing and PDF text selection is not a
function of setroubleshoot, but other components. The attached PDF with bogus
behavior was created by some other GTK component which I cannot identify as
sealert simply calls GTK for printing. Printing seems to work fine in F-7, so
something in GTK printing got fixed.

Copying test is best done with the "Copy Alert" function in the browser because
gtkhtml2 which is used to render the text in the browser is not smart copying
HTML to the clipboard. Perhaps one day we'll switch to using gtkmozembed for
HTML rendering which does have better support.

Note You need to log in before you can comment on or make changes to this bug.