Bug 217923 - Anaconda does not alert you that the installation is too big for the parition before installing
Anaconda does not alert you that the installation is too big for the parition...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-30 14:43 EST by kentphilip
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-28 13:22:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description kentphilip 2006-11-30 14:43:29 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 7.0; Windows NT 5.1; .NET CLR 1.1.4322; .NET CLR 2.0.50727; InfoPath.1; .NET CLR 3.0.04506.30)

Description of problem:
Anaconda does not alert you on the size of the install (like it did in previous versions, when it embedded system-config-packages into the screen) vs the ammount of space you have to install on, so you do not know if the install is too big. Plus, if the install is too big, it just fails in file copy, you are not told beforehand, so you have to reboot the disk and ajust the settings (and if it fails again, you will probably be annoyed by now).

Version-Release number of selected component (if applicable):


How reproducible:
Always


Steps to Reproduce:
1. Boot the install CD
2. Go through
3. Begin the install.

Actual Results:
Install gives no alert on required disk space or if disk is full.

Expected Results:
It should tell you how much disk space the install takes vs the ammount you have on the disk/partition, and alert you if the install is too big.

Additional info:
Comment 1 Chris Lumens 2007-02-28 13:22:56 EST
Due to doing dependency resolution at package selection time instead of having
pre-calculated dependencies, we can no longer offer a size estimate on the
package selection screen.  However, we do check that the size of the installed
package set will fit in the amount of space you've partitioned up.  This check
is pretty good, but not foolproof - for instance, you can easily confuse it by
splitting your free space up into a variety of partitions for things like /var
and /usr.  The package headers don't give us fine-grained enough information to
handle that situation, so you will still have to have a large enough / partition.

I have just verified that this check is being performed and does work.

Note You need to log in before you can comment on or make changes to this bug.