Bug 217928 - jbd I/O errors after ext3 orphan processing on readonly device
jbd I/O errors after ext3 orphan processing on readonly device
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: kernel (Show other bugs)
4.4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Eric Sandeen
Brian Brock
:
Depends On: 173350
Blocks: 231553
  Show dependency treegraph
 
Reported: 2006-11-30 14:59 EST by Rob Kenna
Modified: 2007-11-16 20:14 EST (History)
10 users (show)

See Also:
Fixed In Version: RHBA-2007-0791
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-15 11:16:44 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 2 RHEL Product and Program Management 2006-11-30 15:38:43 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 4 Eric Sandeen 2006-12-07 13:24:23 EST
Update description to something more descriptive.
Comment 7 Eric Sandeen 2007-03-08 17:02:07 EST
So, for 2.6 kernels, lvm isn't rejecting these IOs, and the panics don't happen.

However, I think ext3 should still be checking for readonly, and skipping orphan
recovery if the block device policy is RO.

Since this stuff is upstream and also in rhel3 at this point, rhel4 and rhel5
should get the same treatment - skip orphan processing on readonly devices, and
handle (one way or another) ro->rw transitions of filesystems w/ unprocessed
orphan lists.

I'll send a patch to do so, and we need another bug for RHEL5.

-Eric
Comment 9 RHEL Product and Program Management 2007-04-18 18:44:43 EDT
This request was evaluated by Red Hat Kernel Team for inclusion in a Red
Hat Enterprise Linux maintenance release, and has moved to bugzilla 
status POST.
Comment 10 Jason Baron 2007-06-27 10:45:52 EDT
committed in stream U6 build 55.13. A test kernel with this patch is available
from http://people.redhat.com/~jbaron/rhel4/
Comment 13 errata-xmlrpc 2007-11-15 11:16:44 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0791.html

Note You need to log in before you can comment on or make changes to this bug.