Bug 21793 - Setup dies abnormally when attempting to install using pcmcia boot image over NFS
Setup dies abnormally when attempting to install using pcmcia boot image over...
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.0
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-12-06 00:10 EST by irwright
Modified: 2007-04-18 12:30 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-06 10:46:06 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description irwright 2000-12-06 00:10:05 EST
Introduction:

Red Hat 7 was chosen to be installed on a Toshiba Libretto 70CT; this is a palmtop computer. Specs for this particular machine are as follows: 
Pentium 75mhz, 6.5GB hard drive, 16MB RAM. Floppy drive is pcmcia based. When the machine boots, the BIOS handles the pcmcia floppy 
drive, however, once Linux gets going, it is unable to access this drive anymore. This is one of the major reasons Red Hat was chosen: as only 
one floppy disk is needed to get going, linux is already running when the BIOS gives up control of the floppy drive, rendering it unusable without 
linux-specific drivers.

It should be noted that there are many others who have installed prior versions of Red Hat on a Toshiba Libretto, so I do not believe this is the 
fault of the machine. I have yet to find anybody who has installed or attempted to install Red Hat 7 on one, however.

Steps taken before the error:

Disk image used was pcmcia.
Booted to install in text mode as graphical mode is hard to use on the Libretto's tiny screen.
This installation was attempted via an NFS link to a Slack 7 server; both Intel EtherExpress & 3COM 3C589D-TP pcmcia network cards were 
used.

IP addressing is assigned and the installation begins from the Red Hat 7 CD mounted on the Slack 7 server. Fdisk is used to create partition 
table, installation so far proceeds normally.

Notified of "Low Memory" and prompted to write new partition table to disk immediately.
Selected Yes.
Authentication Configuration came up. Left defaults and hit OK.
"Reading Package Information" dialog briefly flashed on screen, then:

The error: (this is being rekeyed by hand)

Exception Occurred
An internal error occured in the installation program. Please report this error to Red Hat (through the bugzilla.redhat.com web site) as soon as 
possible. The information on this failure may be saved to a floppy disk, and will help Red Hat in fixing the problem.

Traceback ( innermost last):
   File "/usr/bin/anaconda",. line 438, in ?
      intf.run( todo, test = test)
   File
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/tex
t.py", line 1030, in run
      rc = apply (step[1](), step[2])
   File
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/tex
tw/packages_text.py", line 32, in __call__
      todo.getHeaderList()
   File
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/tod
o.py", line 532, in getHeaderList
      self.hdList = self.method.readHeaders()
   File
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/ima
ge.py", line 22, in readHeaders
      return HeaderListFromFile(self.tree + 
"/RedHat/base/hdlist")
   File
"/var/tmp/anaconda-7.0.1//usr/lib/anaconda/com
ps.py", line 136, in __init__
      hdlist = rpm.readHeaderListFromFile(path)
rpm.error: (2, 'No such file or directory')

Last thoughts:

I of course have no idea what this means. I am very new to linux and was surprised that I was able to get the NFS link up so easily, to be 
honest. At any rate, here's the "bug", please let me know what you find on it. :)
Comment 1 Michael Fulbright 2000-12-06 10:46:03 EST
This looks like the NFS install image was not setup correctly, and the installer
could not find the files it required for the install to continue. Make sure you
have all of the CDs copied onto the NFS server and point the installer at the
proper path.

Note You need to log in before you can comment on or make changes to this bug.