Bug 217973 - Invalid mkpart size trunctations on gpt disklabels.
Invalid mkpart size trunctations on gpt disklabels.
Status: CLOSED CURRENTRELEASE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: parted (Show other bugs)
4.3
i686 Linux
medium Severity low
: ---
: ---
Assigned To: David Cantrell
Brock Organ
:
: 217979 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-30 17:59 EST by Magnus Hagebris
Modified: 2008-03-14 22:41 EDT (History)
1 user (show)

See Also:
Fixed In Version: parted-1.6.19-19.EL
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-14 22:41:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Magnus Hagebris 2006-11-30 17:59:07 EST
Description of problem:  
Tried to create 1 MiB partition, but instead got 1 sector. That just cannot be  
correct.  
    
Version-Release number of selected component (if applicable):    
'GNU Parted 1.8.0' from http://people.redhat.com/dcantrel/rhel/parted/i386/   
Ok, not official 1.6.19.EL version, but still a problem... 
    
How reproducible:    
-  
     
Steps to Reproduce:    
1.  # parted -s /dev/sdc mklabel gpt  
2.  # parted -s /dev/sdc unit MiB mkpart primary ext3 0 1  
3.  # parted -s /dev/sdc unit MiB print  
  
Actual results:    
  
 Model: HP HSV101 (scsi)  
Disk /dev/sdc: 21504MiB  
Sector size (logical/physical): 512B/512B  
Partition Table: gpt  
  
Number  Start    End      Size     File system  Name     Flags  
 1      0.02MiB  0.02MiB  0.00MiB               primary  
   
    
Expected results:    
  
 Model: HP HSV101 (scsi)  
Disk /dev/sdc: 21504MiB  
Sector size (logical/physical): 512B/512B  
Partition Table: gpt  
  
Number  Start    End      Size     File system  Name     Flags  
 1      0.02MiB  1.00MiB  0.98MiB               primary  
    
  
Additional info:    
 
Not a big deal since I can simply do this instead:  
# parted -s /dev/sdc unit s mkpart primary ext3 0 2048  
Warning: You requested a partition from 0s to 2048s.  
The closest location we can manage is 34s to 2048s.  Is this still acceptable  
to you?  
 
Comment: Would be nice it this was forced in script mode.. 
 
# parted -s /dev/sdc unit s mkpart primary ext3 34 2048  
# parted -s /dev/sdc unit MiB print  
  
Model: HP HSV101 (scsi)  
Disk /dev/sdc: 21504MiB  
Sector size (logical/physical): 512B/512B  
Partition Table: gpt  
  
Number  Start    End      Size     File system  Name     Flags  
 1      0.02MiB  1.00MiB  0.98MiB               primary
Comment 1 David Cantrell 2007-08-14 17:04:05 EDT
This is a bug with the -s mode for parted(8).  It should only prompt with the -i
option.  The -s option should always suppress interactive prompts and take the
default/appropriate action.  Flagging for 4.7.
Comment 2 David Cantrell 2007-10-31 15:08:57 EDT
*** Bug 217979 has been marked as a duplicate of this bug. ***
Comment 3 RHEL Product and Program Management 2007-11-28 23:23:08 EST
This request was evaluated by Red Hat Product Management for inclusion in a Red
Hat Enterprise Linux maintenance release.  Product Management has requested
further review of this request by Red Hat Engineering, for potential
inclusion in a Red Hat Enterprise Linux Update release for currently deployed
products.  This request is not yet committed for inclusion in an Update
release.
Comment 5 David Cantrell 2008-03-14 22:41:37 EDT
The -s switch is working fine in parted-1.6.19-19.EL in RHEL-4.  The 'unit' command is not available in 
RHEL-4, but is available in RHEL-5.  If you are experiencing problems with the RHEL-5 parted package, 
please file a bug for that release.

Note You need to log in before you can comment on or make changes to this bug.