Bug 217978 - GTKWarning during yumex via console
GTKWarning during yumex via console
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: yumex (Show other bugs)
6
i686 Linux
medium Severity low
: ---
: ---
Assigned To: Tim Lauridsen
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-11-30 19:18 EST by Austin
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-03 10:16:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Austin 2006-11-30 19:18:11 EST
Description of problem: Running yumex from a gnome-terminal, I saw some errors
and warnings. These are being reported here.


Version-Release number of selected component (if applicable): 1.2.0


How reproducible: ALT+F2 --> gnome-terminal --> su - --> yumex (Well, that's all
I did anyhow)


Actual results:
[root@localhost ~]# yumex
GUI Setup Completted
Mirrordetection : fastest
Yum Version : 3.0.1 (/usr/share/yum-cli)
Using http_proxy=http://proxy:8080
[Yum] Loading "installonlyn" plugin
Failure getting
ftp://mirrors.tummy.com/pub/rpm.livna.org/fedora/6/i386/repodata/repomd.xml: 
  --> [Errno 4] IOError: [Errno ftp error] (113, 'No route to host')
Trying other mirror.
/usr/lib/python2.4/site-packages/yumex/yumexDialogs.py:345: GtkWarning: Failed
to set text from markup due to error parsing markup: Error on line 1 char 62:
Odd character 'a', expected a '=' after attribute name 'object' of element
'yumex.yumexBase.yumexBase'
  self.extraLabel.set_markup( "<span size=\"small\">%s</span>" % text )
Failure getting
ftp://mirrors.tummy.com/pub/rpm.livna.org/fedora/testing/6/i386/repodata/repomd.xml:

  --> [Errno 4] IOError: [Errno ftp error] (113, 'No route to host')
Trying other mirror.
Failure getting
ftp://alviss.et.tudelft.nl/pub/fedora/extras/6/i386/repodata/repomd.xml: 
  --> [Errno 4] IOError: [Errno ftp error] timed out
Trying other mirror.
sqlite cache needs updating, reading in metadata
sqlite cache needs updating, reading in metadata
Repository initialization completed in 296.11 seconds



Expected results:
a) Not to have FTP errors going through proxy (web browser works fine using same
proxy)
b) Not have the python error in yumexDialogs.py

Additional info:
Grabbing the FTP URLs listed via the browser works fine.
Comment 1 Tim Lauridsen 2006-12-04 02:46:16 EST
try open a console.
su - (to root)
export ftp_proxy=http://proxy:8080
yumex

Let me know if it works, and i will make some ftp_proxy support in yumex.

Then gtk warning is not importent, it happens because not every thing can be
written using pango markup.
Comment 2 Austin 2006-12-04 03:46:13 EST
I had already thought of this. As a precautionary tactic, I have set all
combinations of upper and lower case environment variables (that I could think
of) to the given proxy :

[root@localhost ~]$ env | grep -i proxy
PROXY=http://proxy:8080
http_proxy=http://proxy:8080
FTP_PROXY=http://proxy:8080
ftp_proxy=http://proxy:8080
HTTPS_PROXY=http://proxy:8080
https_proxy=http://proxy:8080
proxy=http://proxy:8080
HTTP_PROXY=http://proxy:8080

This setup existed at the time of the initial bug report.
Comment 3 Austin 2006-12-05 19:28:37 EST
Just updating the hardware it is being run on. (I thought the ix86s would have
been grouped together...)
Comment 4 Tim Lauridsen 2007-01-03 10:16:34 EST
if it dont work with the proxy evironment variable, i cant fix it, all yumex is
doing when you define a proxy in yumex, is setting the http_proxy variable.
The error is occouring at a lower level so i cant fix it, if the proxy variables
dont work.

Note You need to log in before you can comment on or make changes to this bug.