Bug 217996 - blkback: Fix potential grant entry leaks on error
Summary: blkback: Fix potential grant entry leaks on error
Status: CLOSED DUPLICATE of bug 218355
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel-xen   
(Show other bugs)
Version: 5.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Rik van Riel
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-01 05:29 UTC by Herbert Xu
Modified: 2007-11-30 22:07 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-22 21:12:04 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Herbert Xu 2006-12-01 05:29:37 UTC
Changeset 11888 from xen-unstable.

[BLOCK] blkback: Fix potential grant entry leaks on error

As it stands grant entries for the actual data are mapped in bulk.
If one of the earlier entries fail to be mapped, it can cause all
subsequent entries to be leaked if they were successfully mapped.

This patch changes it so that we will continue to reap grant entries
even when an error is detected.

Signed-off-by: Herbert Xu <herbert@gondor.apana.org.au>

Comment 2 Rik van Riel 2006-12-02 01:11:18 UTC
Just posted to rhkernel-list.

Comment 3 Jay Turner 2006-12-06 22:50:11 UTC
QE ack for RHEL5.

Comment 4 Herbert Xu 2006-12-22 21:12:04 UTC

*** This bug has been marked as a duplicate of 218355 ***


Note You need to log in before you can comment on or make changes to this bug.