Bug 218006 - Exporting oo docs with "Luxi mono" font into pdf generates ugly output
Exporting oo docs with "Luxi mono" font into pdf generates ugly output
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
5
All Linux
medium Severity medium
: ---
: ---
Assigned To: Caolan McNamara
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-01 01:26 EST by Joachim Backes
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-01 05:44:13 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
oo doc (7.35 KB, application/x-gzip)
2006-12-01 01:26 EST, Joachim Backes
no flags Details
generated PDF file (39.91 KB, application/x-gzip)
2006-12-01 01:29 EST, Joachim Backes
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenOffice.org 60774 None None None Never
OpenOffice.org 72171 None None None Never

  None (edit)
Description Joachim Backes 2006-12-01 01:26:49 EST
Description of problem:


Version-Release number of selected component (if applicable):


How reproducible: every time.


Steps to Reproduce:
1. LOad the attached oo document
2.Export it to a pdf file with the default controls
3.View the pdf with evince (or acroread)
  
Actual results:
Some lines with double quotes ( " char) are presented incorrectly.

Expected results:
All lines are presented well

Additional info: Printing such a pdf generates a correct output on Paper.
I have attaches both the oo doc in odt format and the generated pdf file.
Comment 1 Joachim Backes 2006-12-01 01:26:49 EST
Created attachment 142542 [details]
oo doc
Comment 2 Joachim Backes 2006-12-01 01:29:10 EST
Created attachment 142543 [details]
generated PDF file

THe exported PDF file has been attached!
Comment 3 Joachim Backes 2006-12-01 01:35:10 EST
I forgot to explain my problem: When generating an oo document (odt style) and
using the "Luxy mono" font and exporting such an oo document to pdf (using the
default controls), then the lines containing pairs of double quotes are
displayed in an ugly manner by PDF readers such as evince or acroread.

Printing such a PDF file is OK, no double quote problem..

The same problem appears in FC6 too, and when using staroffice instead OO.
Comment 4 Caolan McNamara 2006-12-01 05:44:13 EST
Reproducable

We've seen something like this before, as
http://qa.openoffice.org/issues/show_bug.cgi?id=60774 but that one spontaneously
went away but it's hauntingly similar to this problem.

Moving this upstream as http://www.openoffice.org/issues/show_bug.cgi?id=72171
to see if we can get to the bottom of this once and for all.

There's *something* with quotes and monospace fonts going on

Note You need to log in before you can comment on or make changes to this bug.