Bug 218040 - luci reports "unknown" as cluster name if cluster creation fails (not reproducible at will)
Summary: luci reports "unknown" as cluster name if cluster creation fails (not reprodu...
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: conga   
(Show other bugs)
Version: 5.0
Hardware: All Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Ryan McCabe
QA Contact: Corey Marthaler
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-01 14:44 UTC by Len DiMaggio
Modified: 2009-04-16 22:42 UTC (History)
6 users (show)

Fixed In Version: RC
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-08 02:23:55 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Screen shot of "unknown" cluster (111.61 KB, image/png)
2006-12-01 14:44 UTC, Len DiMaggio
no flags Details

Description Len DiMaggio 2006-12-01 14:44:49 UTC
Description of problem:
luci reports "unknown" as cluster name if cluster creation fails (not
reproducible at will)

For example - in debugging the problem described in
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=217724, I did see this
problem of an "unknown" cluster a couple of times. luci didn;t write anything
interesting to its debug log.

Jim Parsons suggested that I log this bz - even though it's not yet reproducible
ar will - while I'm looking at determining the exact cause/sequence of actions
to recreate the bug.

Version-Release number of selected component (if applicable):
luci-0.8-25.el5

How reproducible:
Intermittent - maybe 20% of the time

Steps to Reproduce:
1. Create a new cluster, but have that cluster creation fail - for example, due
to the bug described in https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=217724
  
Actual results:
See the first attachment.

Expected results:
A more helpful error message.

Additional info:
https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=217724

Comment 1 Len DiMaggio 2006-12-01 14:44:50 UTC
Created attachment 142569 [details]
Screen shot of "unknown" cluster

Comment 2 Ryan McCabe 2006-12-01 16:44:09 UTC
I believe this occurs when ricci is unable to get information about the cluster
from modclusterd because modclusterd (and/or cluster infrastructure) is not
running. What luci should do is use the information about the cluster (name,
nodes, etc.) that is does have in its database instead of simply printing
'[unknown]' and nothing else.

Comment 3 Ryan McCabe 2006-12-06 21:17:27 UTC
The fix for this is in -HEAD now. I'll commit it to -RHEL5 once all the
appropriate flags are set.

Comment 4 Len DiMaggio 2007-01-09 16:06:19 UTC
Unable to exactly recreate the problem - but, I never was able to. Tried to
cause the problem by killing modclusterd, and the "unknown" error did not
result. Marking the bz as verified.

Comment 5 RHEL Product and Program Management 2007-02-08 02:23:55 UTC
A package has been built which should help the problem described in 
this bug report. This report is therefore being closed with a resolution 
of CURRENTRELEASE. You may reopen this bug report if the solution does 
not work for you.



Note You need to log in before you can comment on or make changes to this bug.