Bug 218053 - RPMs not multilib safe
RPMs not multilib safe
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: audit (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Steve Grubb
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-01 11:10 EST by Ulrich Drepper
Modified: 2008-01-06 08:51 EST (History)
0 users

See Also:
Fixed In Version: audit-1.5.6-2.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-06 08:51:58 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Ulrich Drepper 2006-12-01 11:10:56 EST
Description of problem:
On biarch systems there is always an install conflict because of
/etc/libaudit.conf.  The file is copied into the chroot-ed install tree when
building the RPM and the date is not adjusted.  This means when the RPM is
installed the dates in the two biarch RPMs differs and therefore we get a conflict.

Version-Release number of selected component (if applicable):
1.3-2.fc6

How reproducible:
always

Steps to Reproduce:
1.install any audit release on biarch system
2.
3.
  
Actual results:
  Updating  : audit-libs                                           [
4/38]warning: /etc/libaudit.conf created as /etc/libaudit.conf.rpmnew


Expected results:
  Updating  : audit-libs                                           [ 4/38]


Additional info:
Two possible solutions

1. move the file into the audit RPM of which there is only one installed.
   But maybe audit-libs can be installed without audit in which case this
   is no option.

2. Use

     touch -r REFFILE /var/tmp/..../etc/libaudit.conf

   after installing in the chroot-ed install dir and before packaging to
   unify the timestamps.  For REFFILE use a file from the source tree which
   isn't touched during the build process
Comment 1 Steve Grubb 2006-12-01 11:28:39 EST
Hmm...option 1 can't be done since the config file is for use by libaudit and
not the daemon. I assume option 2 is just a change to the spec file. I think I
could do:

touch -r ./audit.spec $RPMBUILD_ROOT/etc/libaudit.conf

since there is a spec file in the tar ball that does not get used.
Comment 2 Steve Grubb 2006-12-01 11:37:28 EST
audit-1.3-3 was built into rawhide with the above fix. I'll pick up the change
next time FC5/6 audit package is updated and push the change into RHEL5. Thanks
for pointing this out.
Comment 3 Till Maas 2008-01-06 08:51:58 EST
fixed in Fedora 7

Note You need to log in before you can comment on or make changes to this bug.