Bug 218064 - RPMs not multilib safe
Summary: RPMs not multilib safe
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: openssl (Show other bugs)
(Show other bugs)
Version: rawhide
Hardware: All Linux
medium
medium
Target Milestone: ---
Assignee: Tomas Mraz
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-01 17:18 UTC by Ulrich Drepper
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-09-24 19:48:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Ulrich Drepper 2006-12-01 17:18:55 UTC
Description of problem:
The openssl RPMs on biarch systems create conflicts at install time because the
timestamps of some shared files differ.  The affected files I saw the last time are:

/etc/pki/tls/certs/ca-bundle.crt
/etcphi/tls/openssl.cnf


Version-Release number of selected component (if applicable):
openssl-0.9.8b-8.0.1.fc6

How reproducible:
always

Steps to Reproduce:
1.install both openssl RPMs on biard system
2.
3.
  
Actual results:
.rpmnew files for the two files above

Expected results:
no such .rpmnew files

Additional info:
The solution is to use

  touch -r REFFILE $RPMROOT/etc/pki/tls/openssl.cnf

(and similarly for ca-bundle.crt) with REFFILE being a file in the source tree
which isn't touched during the build process.

Comment 1 Tomas Mraz 2007-09-24 19:48:03 UTC
The current rpm in devel should not produce such bogus .rpmnew files (differing
only by timestamp).



Note You need to log in before you can comment on or make changes to this bug.