Bug 218070 - gaim/gstreamer segfaults when when trying to play audio notifications
gaim/gstreamer segfaults when when trying to play audio notifications
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: gaim (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Warren Togami
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-01 12:49 EST by Carl Roth
Modified: 2008-05-06 13:00 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-05-06 13:00:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Gdb messages from running gaim (29.89 KB, text/plain)
2006-12-01 12:49 EST, Carl Roth
no flags Details
Gdb trace of gaim session (51.37 KB, application/octet-stream)
2006-12-01 15:44 EST, Carl Roth
no flags Details

  None (edit)
Description Carl Roth 2006-12-01 12:49:09 EST
Description of problem:
Gaim segfaults when starting up.  The sound notification scheme is set to
"Auto".  If I turn off sound notifications, it doesn't segfault.

My sound system is Alsa, and my desktop system is KDE.  I'm including the output
of 'aplay -l' below.  My asound.conf is routing sound through the USB audio
device; gstreamer-properties is able to play test sounds through the device
without a problem.

**** List of PLAYBACK Hardware Devices ****
card 0: Intel [HDA Intel], device 0: STAC92xx Analog [STAC92xx Analog]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 0: Intel [HDA Intel], device 1: STAC92xx Digital [STAC92xx Digital]
  Subdevices: 1/1
  Subdevice #0: subdevice #0
card 1: U0x47f0xc001 [USB Device 0x47f:0xc001], device 0: USB Audio [USB Audio]
  Subdevices: 1/1
  Subdevice #0: subdevice #0

Version-Release number of selected component (if applicable):
gaim-2.0.0-0.22.beta5.fc6
gstreamer08-0.8.12-8.fc6
gstreamer-plugins-base-0.10.10-1.fc6
gstreamer-plugins-ugly-0.10.4-3.lvn6
gstreamer-tools-0.10.10-2.fc6
gstreamer-0.10.10-2.fc6
gstreamer-plugins-good-0.10.4-1.fc6
gstreamer-plugins-bad-0.10.3-1.fc6

How reproducible:
Always

Steps to Reproduce:
1. start gaim
2.
3.
  
Actual results:
Gaim segfaults

Expected results:
Gaim should not segfault

Additional info:
I'm including a gdb session capture that shows a segfault while calling a
gstreamer API.
Comment 1 Carl Roth 2006-12-01 12:49:09 EST
Created attachment 142588 [details]
Gdb messages from running gaim
Comment 2 Warren Togami 2006-12-01 13:11:04 EST
gaim
gstreamer
gtk2
glib2

Please install the exact matching versions of debuginfo for these packages and
get another gdb traceback.
Comment 3 Carl Roth 2006-12-01 15:44:47 EST
Created attachment 142621 [details]
Gdb trace of gaim session
Comment 4 Carl Roth 2006-12-01 15:45:40 EST
I installed the debug symbols, here are the versions:

gaim-2.0.0-0.22.beta5.fc6
gaim-debuginfo-2.0.0-0.22.beta5.fc6
glib2-2.12.3-2.fc6
glib2-debuginfo-2.12.3-2.fc6
gtk2-2.10.4-5.fc6
gtk2-debuginfo-2.10.4-5.fc6
gstreamer-0.10.10-2.fc6
gstreamer-debuginfo-0.10.10-2.fc6

The new gdb traceback is attached.
Comment 5 Warren Togami 2006-12-05 15:57:18 EST
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=397788
Debian seems to be having similar problems with gaim and gstreamer, but only
x86_64.  You say your problems were on i386?
Comment 6 Carl Roth 2006-12-05 16:31:42 EST
This was an i386/i686 system.
Comment 7 Warren Togami 2006-12-06 14:51:56 EST
http://svn.debian.org/wsvn/pkg-gnome/packages/unstable/gaim/debian/patches/
I am testing patch 12 from Debian.
http://people.redhat.com/wtogami/temp/gaim-gstreamer/
Please try this FC6 i386 package and report back.
- Does it crash?
- Does sound work?
Comment 8 Carl Roth 2006-12-07 09:31:05 EST
I tried your build 27 gaim package, and I get the following result:

 * gaim starts correctly, does not crash
 * sound does not work

Messages in the gaim log mention

  sound: Unable to create GStreamer audiosink.

but when I run gstreamer-properties separately, test sounds do work.
Comment 9 Warren Togami 2006-12-07 12:45:16 EST
"sound: Unable to create GStreamer audiosink."

Does this mean that it is unable to find a suitable output device?

Strange that gstreamer-properties test would work though...
Comment 10 Bug Zapper 2008-04-04 01:03:01 EDT
Fedora apologizes that these issues have not been resolved yet. We're
sorry it's taken so long for your bug to be properly triaged and acted
on. We appreciate the time you took to report this issue and want to
make sure no important bugs slip through the cracks.

If you're currently running a version of Fedora Core between 1 and 6,
please note that Fedora no longer maintains these releases. We strongly
encourage you to upgrade to a current Fedora release. In order to
refocus our efforts as a project we are flagging all of the open bugs
for releases which are no longer maintained and closing them.
http://fedoraproject.org/wiki/LifeCycle/EOL

If this bug is still open against Fedora Core 1 through 6, thirty days
from now, it will be closed 'WONTFIX'. If you can reporduce this bug in
the latest Fedora version, please change to the respective version. If
you are unable to do this, please add a comment to this bug requesting
the change.

Thanks for your help, and we apologize again that we haven't handled
these issues to this point.

The process we are following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.

And if you'd like to join the bug triage team to help make things
better, check out http://fedoraproject.org/wiki/BugZappers
Comment 11 Bug Zapper 2008-05-06 13:00:03 EDT
This bug is open for a Fedora version that is no longer maintained and
will not be fixed by Fedora. Therefore we are closing this bug.

If you can reproduce this bug against a currently maintained version of
Fedora please feel free to reopen thus bug against that version.

Thank you for reporting this bug and we are sorry it could not be fixed.

Note You need to log in before you can comment on or make changes to this bug.