Bug 21811 - Can't paste from konsole into forwarded X application
Summary: Can't paste from konsole into forwarded X application
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kdebase   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: Aaron Brown
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-06 17:29 UTC by Stephen Rasku
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2002-03-27 15:19:44 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Stephen Rasku 2000-12-06 17:29:49 UTC
I am running dtmail on Solaris 7.  It is forwarded back to my Linux box 
via ssh.  

When I attempt select some text in the konsole and attempt it to paste it
by pressing the middle button, it is ignored.  When I select some text in
Netscape and attempt to paste it by pressing the middle button, it works
fine.  I can also paste from a konsole into a (local) kmail fine as well.

Comment 1 Bernhard Rosenkraenzer 2000-12-12 17:08:26 UTC
This seems to be a problem on the Solaris side - pasitng to other (even remote)
Linux applications works perfectly.
My guess is Solaris catches the mouse event.

Comment 2 Stephen Rasku 2000-12-13 04:10:33 UTC
If it was a problem on the Sun side, I would not be able to paste from (local
Linux) Netscape into dtmail.  Just for kicks, I just tried pasting from Mozilla
(Linux build 2000120808).  That works.  Plain xterm works as well.  It appears
that none of the KDE applications work.  konsole, kvt, and kmail failed to
paste.  If I can get GNOME set up on my machine, I will do some tests with it
and let you know what happens.  Reopening...

Comment 3 Stephen Rasku 2000-12-13 04:28:40 UTC
Just switched to GNOME.  Pasting from gnome-terminal works fine as well.

Comment 4 Preston Brown 2002-03-27 14:48:07 UTC
 Bero, does this work with KDE 3 and the new Qt selection mechanisms?

Comment 5 Bernhard Rosenkraenzer 2002-03-27 15:19:39 UTC
I have no idea, since I don't have access to any sun systems. Linux<->Linux and 
Linux<->FreeBSD (the only 2 OSes I have access to) has always  
worked.

Comment 6 Stephen Rasku 2002-04-05 08:37:31 UTC
This WORKSFORME on KDE 3.0.


Note You need to log in before you can comment on or make changes to this bug.