Bug 218113 - the encryption password prompt should be explicit
Summary: the encryption password prompt should be explicit
Status: CLOSED WONTFIX
Alias: None
Product: Fedora
Classification: Fedora
Component: util-linux   
(Show other bugs)
Version: 6
Hardware: All
OS: Linux
medium
low
Target Milestone: ---
Assignee: Karel Zak
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2006-12-01 20:41 UTC by David Monniaux
Modified: 2007-11-30 22:11 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-05 17:20:48 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Monniaux 2006-12-01 20:41:37 UTC
Description of problem:
sudo and mount have the same "Password:" prompt and one cannot know when doing
sudo mount /encrypted/partition whether the requested password is the sudo
password (because of the sudo timeout) or the encryption password

Version-Release number of selected component (if applicable):


How reproducible:
always

Steps to Reproduce:
1. sudo mount /encrypted/partition
2.
3.
  
Actual results:
If sudo was used recently, get a "Password:" prompt expecting the encryption
password.
Else, get an identical prompt expecting the sudo password (account's password).

Expected results:
The two prompts should be different.

Additional info:

Comment 1 Karel Zak 2007-04-05 17:20:48 UTC
Please, see "man sudoers", the passprompt option.


Note You need to log in before you can comment on or make changes to this bug.