Bug 218121 - yum dependency resolver grabs too much
yum dependency resolver grabs too much
Status: CLOSED DUPLICATE of bug 200643
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-01 16:26 EST by Michal Jaegermann
Modified: 2014-01-21 17:56 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-25 14:50:27 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2006-12-01 16:26:40 EST
Description of problem:

On my test installation there are _only_ x86_64 and noarch packages.
With the lastest rawhide update a try of 'yum update' causes:

Installing:
 compat-db               i386       4.3.29-2.fc7     development       1.9 M
     replacing  db4-devel.x86_64 4.3.29-9.fc6
......

Installing for dependencies:
 glibc                   i686       2.5.90-8         development       5.2 M
 libgcc                  i386       4.1.1-41         development        78 k
 libstdc++               i386       4.1.1-41         development       346 k

Bummer!  That is definitely not a desired result.  BTW -
compat-db.x86_64 is scheduled for an installation too.

OK, lets try the other way which luckily works:

# yum update 'db4*'
Updating:
 db4                     x86_64     4.5.20-3.fc7     development       1.1 M
 db4-devel               x86_64     4.5.20-3.fc7     development       2.4 M
Updating for dependencies:
 compat-db               x86_64     4.3.29-2.fc7     development       1.8 M

Oh!  No i386 packages and related dependencies this time!  And
following that with 'yum update' brings in all remaining packages
without any attempts to add anything for an unneeded architecture.

So, depending on how you are doing that effects are different.

Version-Release number of selected component (if applicable):
yum-3.0.1-2.fc7
Comment 1 Jeremy Katz 2007-04-25 14:50:27 EDT

*** This bug has been marked as a duplicate of 200643 ***

Note You need to log in before you can comment on or make changes to this bug.