Bug 218123 - EDD calls in ks.cfg is failing for X86_64 version of RHEL5 beta2
Summary: EDD calls in ks.cfg is failing for X86_64 version of RHEL5 beta2
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: anaconda   
(Show other bugs)
Version: 5.0
Hardware: All Linux
urgent
urgent
Target Milestone: ---
: ---
Assignee: Anaconda Maintenance Team
QA Contact:
URL:
Whiteboard:
Keywords: Regression
Depends On:
Blocks: 200812
TreeView+ depends on / blocked
 
Reported: 2006-12-01 21:34 UTC by Rezwanul Kabir
Modified: 2009-06-19 10:22 UTC (History)
2 users (show)

Fixed In Version: 5.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-11 02:06:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Rezwanul Kabir 2006-12-01 21:34:15 UTC
Description of problem:

EDD calls in ks.cfg ( i.e. --biosdisk, --biospart etc.) is failing ONLY for 
x86_64 install. i386 installations are however all PASSING.
The root of the issue, I believe, lies below:

 In isys.py file, we have:

  def doGetBiosDisk(mbrSig):
    if rhpl.getArch() != "i386":
        return None
    return _isys.getbiosdisk(mbrSig)

  Thus for non-x86 arch doGetBiosDisk() is returning NULL and hence the issue.

      

Version-Release number of selected component (if applicable):
anaconda-11.1.2.16

How reproducible:
Always

Steps to Reproduce:
1. Use ks.cfg with EDD options
2. Start harddrive based unattended installation
3.
  
Actual results:
Install will abort with errors

Expected results:
Install should proceed

Additional info:

Comment 2 Amit Bhutani 2006-12-06 06:59:30 UTC
Breaks Factory as well as Redeployment CD i.e. DSA, so marking as urgent.

Comment 3 Larry Troan 2006-12-07 20:58:43 UTC
This is a bug and therefore doesn't require a PM ACK but there is confusion in
the ranks. This is a critical bug for Dell so raising it as an exception for
RHEL5 consideration prior to rc.

Per Jeremy, it's a regression from RHEL4 caused by a workaround for bug 214653.
The fix is trivial.


Comment 7 Jeremy Katz 2006-12-12 21:01:03 UTC
Committed my patch

Comment 8 Amit Bhutani 2006-12-13 15:44:31 UTC
Jeremy- Can you post the anaconda version this patch went into so we can track ?

Comment 9 Jeremy Katz 2006-12-13 19:52:34 UTC
A version dated after the time of the commit; instead of trying to find the
version, you'll be better looking at the changelog for anaconda for the bug#.

Comment 10 Jose De la Rosa 2007-01-03 16:43:58 UTC
RHEL 5 Release Candidate Snapshot 5 (kernel-2.6.18-1.2910.el5) with anaconda-
11.1.2.24 fixes this issue. Changing status to Verified. RH - please close.

Comment 11 Amit Bhutani 2007-01-10 18:36:51 UTC
RH - Please close as fix has been verified as of RCS5.


Note You need to log in before you can comment on or make changes to this bug.