Bug 218130 - Kernel hangs on boot
Kernel hangs on boot
Status: CLOSED DUPLICATE of bug 215154
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-01 17:15 EST by Michael Belanger
Modified: 2007-11-30 17:11 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-22 14:01:46 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen shot of boot hang (1.12 MB, image/jpeg)
2006-12-01 17:15 EST, Michael Belanger
no flags Details
screenshot of boot w/ initcall_debug=1 (1.30 MB, image/jpeg)
2006-12-19 12:23 EST, Michael Belanger
no flags Details

  None (edit)
Description Michael Belanger 2006-12-01 17:15:55 EST
Description of problem:
kernel 2.6.18-1.2849.fc6 hangs on boot.

Version-Release number of selected component (if applicable):


How reproducible:
everytime.

Steps to Reproduce:
1. install 2.2.6.18-1.2849.fc6 kernel on Dell Dimension 8100 w/ livna Nvidia kmod.

2. reboot
  
Actual results:
Hangs -- no panic

Expected results:
Should boot as normal

Additional info:
Comment 1 Michael Belanger 2006-12-01 17:15:56 EST
Created attachment 142631 [details]
screen shot of boot hang
Comment 2 Will Woods 2006-12-01 17:18:02 EST
Does it hang if you aren't using the nvidia module? We (obviously) can't provide
support for nvidia's closed-source software.
Comment 3 Michael Belanger 2006-12-01 18:38:40 EST
I removed the nvidia kmod and it still hangs.

Comment 4 Will Woods 2006-12-05 15:44:02 EST
How about if you try booting without 'quiet rhgb' on the kernel commandline?

(hit 'a' in the GRUB screen to edit the kernel commandline)
Comment 5 Michael Belanger 2006-12-05 15:49:16 EST
Thanks for looking into this Will.. Please see the screenshot attachment I
posted with this bug. it is the result of a boot with quiet and rhgb removed.
Comment 6 Dave Jones 2006-12-18 23:16:36 EST
try booting with initcall_debug=1 
What's the last 2-3 lines it prints after that ?
Comment 7 Michael Belanger 2006-12-19 12:23:43 EST
Created attachment 144018 [details]
screenshot of boot w/ initcall_debug=1

PCI: Bridge: 0000:00:1e.0
   IO window: e000-efff
   MEM window: ff100000-ff2ffffff
   PREFETCH window: 40000000-400fffff
Calling initcall 0xc076d8ae: inet_init+0x0/0x2d2()
NET: Registered protocol family 2

See attached for screenshot
Comment 8 Kevin Crocker 2006-12-19 21:51:19 EST
OK - I;m seeing the same thing - 2.6.18-1.2849 stalls just after the grub menu -
I can't take a screen shot but I can type in the last few lines after i removed
the rhgb and quite flags

PCI: Bridge: 0000:00:1e.0
 IO Window: 4000-4fff
 MEM Window: e0300000-e03fffff
 PREFETCH window: 70000000-71ffffff
PCI: Found IRQ 10 for device 0000:03:01.0
PCI: Sharing IRQ 10 with 0000:00:1f.3
PCI: Sharing IRQ 10 with 0000:00:1f.5
PCI: Sharing IRQ 10 with 0000:03:01.1
NET: Registered protocol family 2

BTW, my ethernet card went flakey at the same time - I always booted into 2798
rather than 2849 because 2849 didn't boot - but the ethernet e1000 type card
wouldn't get found at the hardware acquisition level unless I rebooted three
times - I don't know if it is related - but it sure is a coinicidence. I'm ont
running any special video drivers - I have an ATI card using generic FC6 video

when I run the initcall_debug=1 there is one additional line before the last NET
line above

Calling initcall 0xc076d8ae: inet_init+0x0/0x2xd2()

hm, looks exactly the same as above --- I'm running a Gateway M675 laptop
Comment 9 Michael Belanger 2006-12-22 13:31:28 EST
2.6.18-1.2868.fc6 boots fine!  Was something fixed here?
Comment 10 Jarod Wilson 2006-12-22 14:01:46 EST
Pretty sure this was the auto-apic patch causing problems.

*** This bug has been marked as a duplicate of 215154 ***
Comment 11 Kevin Crocker 2006-12-23 12:00:34 EST
thanks - this is wonderful news that the problem might have been isolated - but
how do I get the machine to boot up - what do I DO?
Comment 12 Jarod Wilson 2007-01-02 16:16:26 EST
(In reply to comment #11)
> thanks - this is wonderful news that the problem might have been isolated - but
> how do I get the machine to boot up - what do I DO?

Ah, sorry, it was a bit hidden in bug 215154. Just add 'apic' to your kernel
boot parameters. Not needed with the latest kernel, only with 2849.

Note You need to log in before you can comment on or make changes to this bug.