Bug 218139 - new tabs don't get updated
Summary: new tabs don't get updated
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: gnome-terminal   
(Show other bugs)
Version: rawhide
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Behdad Esfahbod
QA Contact:
URL:
Whiteboard:
Keywords:
: 215194 (view as bug list)
Depends On:
Blocks: FC7Blocker
TreeView+ depends on / blocked
 
Reported: 2006-12-01 23:10 UTC by David Nielsen
Modified: 2007-11-30 22:11 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-01-24 16:32:05 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Nielsen 2006-12-01 23:10:21 UTC
Description of problem:
When you open a new tab they don't display updates untill you switch away from
them and then back. The original instance is always working perfectly, only
subiquently opened tabs are affected.

Version-Release number of selected component (if applicable):
gnome-terminal-2.16.1-1.fc7

How reproducible:
100%

Steps to Reproduce:
1. open new tab
2. type stuff and notice how nothing happens
3. switch to the another tab then switch back and notice how your text now is
rendered

Comment 1 Michal Jaegermann 2006-12-18 23:51:33 UTC
AFAICS this does not happen right away.  In the first terminal window
you can usually open one additional tab and it will behave normally.
After opening the next one there is a pretty good chance that one
will stare at a blank window.  After a long while a prompt may appear
but nothing is echoed while you type.  That is practically certain
in the next tab to be opened.

In the second terminal window already the first added tab will behave
like described in the report with a practical certainity.

I tried to look with 'strace' and SysRq if there is anything unusual
with a bash behaviour in those new tabs and if there is then I missed
it.

Comment 2 Ola Thoresen 2006-12-21 07:58:48 UTC
I can confirm this on x86_64
gnome-terminal-2.16.1-1.fc7

Quite annoying.

Comment 3 Jeremy Katz 2006-12-22 15:46:22 UTC
*** Bug 215194 has been marked as a duplicate of this bug. ***

Comment 4 Jeremy Katz 2006-12-22 16:09:04 UTC
This doesn't happen on i386.  Downgrading vte and gnome-terminal to the versions
from FC6 doesn't help.  

Comment 5 Nicolas Mailhot 2007-01-06 10:16:12 UTC
Confirming on gnome-terminal-2.16.1-1.fc7 x86_64 (rawhide)

This bug made me forget about term tabs altogether - they're impossible to use now

Comment 6 Deji Akingunola 2007-01-24 07:55:32 UTC
This seems to have been fixed with gnome-terminal-2.17.90-1.fc7 and vte-0.15.2-1.fc7

Comment 7 Saikat Guha 2007-01-24 09:06:10 UTC
Confirmed. 
Tabs are refreshing with 
gnome-terminal-2.16.1-1.fc7
vte-0.15.1-2.fc7


Comment 8 Behdad Esfahbod 2007-01-24 16:32:05 UTC
Great.  Lets close then!


Note You need to log in before you can comment on or make changes to this bug.