This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 218171 - Enable SPF in milter-greylist
Enable SPF in milter-greylist
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: milter-greylist (Show other bugs)
6
All Linux
medium Severity low
: ---
: ---
Assigned To: Enrico Scholz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-02 09:22 EST by Russell Odom
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-02-04 05:48:41 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Russell Odom 2006-12-02 09:22:06 EST
Description of problem:
It would be nice if milter-greylist was built with SPF enabled. Details in the
README at http://hcpnet.free.fr/milter-greylist/README (section 10). 

It will work with libspf2 (http://libspf2.org/), libspf_alt (appears to be
discontinued?) or libspf (http://www.libspf.org/ - seems to be down at the mo)
so I guess it would require a package for one of these to be built too (Dag
Wieers has libspf for FC2&3 at http://dag.wieers.com/packages/libspf/).

Version-Release number of selected component (if applicable): 2.1.12-3
Comment 1 Enrico Scholz 2007-02-04 05:48:41 EST
There is no spf library in FC/FE which can be used with milter-greylist.

Because I do not believe in positive effects of SPF and saw lots of problems
while evaluating 'libspf' with milter-greylist (due to bad code qualitity in
libspf), I am not going to maintain 'libspf*' myself.

Therefore, I will close this bug as deferred. Please reopen it, when a stable
'libspf*' library exists in FC/FE.
Comment 2 Russell Odom 2007-02-04 08:30:17 EST
Not sure if this helps, but ATrpms has libspf2
(http://atrpms.net/dist/fc6/libspf2/). I also found RPMs for libspf and libspf2
by Paul Howarth (http://www.city-fan.org/ftp/contrib/libraries/).

Maybe you'd find libspf2 a little less problematic than libspf? The website
(http://libspf2.org/) makes the right sort of noises about reliability, etc.

This might be a dumb question, but could milter-greylist be built in such a way
that it doesn't require libspf2 but will use if if it's present?
Comment 3 Enrico Scholz 2007-02-04 09:12:54 EST
It has already (more or less untested) support for a '--with spf'
build flag. Just add this manually to 'rpmbuild' or add '%_with_spf 1'
to your ~/.rpmmacros.

For -devel branch I will move to the %bcond_with style without the
leading underscore.



Note You need to log in before you can comment on or make changes to this bug.