Bug 218193 - sylpheed-claws-plugins has broken dependencies in fc4
sylpheed-claws-plugins has broken dependencies in fc4
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: sylpheed-claws-plugins (Show other bugs)
4
All Linux
medium Severity medium
: ---
: ---
Assigned To: Andreas Bierfert
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-02 20:30 EST by Kevin Fenzi
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-04 18:53:01 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Kevin Fenzi 2006-12-02 20:30:01 EST
Description of problem:
The sylpheed-claws-plugins has broken dependencies, and has for the last 61+ days. 

Version-Release number of selected component (if applicable):
2.3.0-2.fc4

How reproducible:
Try and install the version of the package in fc4. It won't install.

From the broken dependency report:

        sylpheed-claws-plugins-etpan-privacy - 2.3.0-2.fc4.i386    (61 days)
        sylpheed-claws-plugins-etpan-privacy - 2.3.0-2.fc4.ppc    (61 days)
        sylpheed-claws-plugins-etpan-privacy - 2.3.0-2.fc4.x86_64    (61 days)

    sylpheed-claws-plugins-etpan-privacy-2.3.0-2.fc4.ppc  requires  libetpan.so.6

There is a current version (2.6.0-1.fc4) checked into CVS and tagged, but it
won't build. The vcalendar plugin ignores the --disable-static flag, and builds
a .a archive. When the package tries to gather debuginfo from this archive it
fails because strip in fc4 can't handle .a files with other .a files in them. 

The solution should be (for not only fc4 but the other versions of the package)
to remove all the .a files and not ship them. 

Something like the following diff should work: 

diff -r1.19 sylpheed-claws-plugins.spec
19c19
< Release:        1%{?dist}
---
> Release:        2%{?dist}
358a359
> find ${RPM_BUILD_ROOT} -type f -name "*.a" -exec rm -f {} ';'
528a530,533
> * Sat Dec 02 2006 Kevin Fenzi <kevin@tummy.com> 
> 2.6.0-2
> - Remove .a libraries to fix build issue on fc4
> 

Note that you should also update fc5/fc6/devel as well to keep the E-V-R happy
for upgrades.
Comment 1 Andreas Bierfert 2006-12-04 04:25:15 EST
Ah I was wondering why it was failing on fc4 strip... I will see that this gets
a rebuild asap so that deps script is happy again ^^ Thanks for reporting.

Note You need to log in before you can comment on or make changes to this bug.