Bug 218196 - Evolution mail client can no longer see folders outside of "INBOX/" imap namespace
Evolution mail client can no longer see folders outside of "INBOX/" imap name...
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: evolution-data-server (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Matthew Barnes
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-02 22:04 EST by Dwayne McGarty
Modified: 2008-03-11 22:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-03-11 22:57:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 317178 None None None Never

  None (edit)
Description Dwayne McGarty 2006-12-02 22:04:32 EST
Description of problem: Evolution mail client can no longer access folders
outside of the "INBOX/" imap namespace on our Cyrus IMAP server.  It worked in
all releases up to and including FC4 release but broke in FC5 and is still
broken in FC6.  







Version-Release number of selected component (if applicable):
Presently running FC6 with evolution components:
evolution-webcal-2.7.1-6
evolution-sharp-0.11.1-10.fc6
beagle-evolution-0.2.10-7.fc6
evolution-data-server-1.8.1-2.fc6
evolution-2.8.1.1-3.fc6



How reproducible: Configure Evolution Account using IMAP server type


Steps to Reproduce:
1. Configure Evolution Account using IMAP server type and on "Receiving Options"
tab, check the "Override server-supplied folder namespace. 
2. Log into new server account to view mail
3. Only INBOX and subfolders of INBOX appear.  Folders under "" and "user/" are
not shown.
  
Actual results:
Only INBOX and "INBOX/" are shown in the interface


Expected results:
There should be folders in INBOX/*, user/* and MySharedFolders/* shown in the
evolution interface.


Additional info:
Evolution has the server defined as IMAP and have tried with "Override
server-supplied folder namespace" checked (how it used to work) and unchecked.

When the cyrus imap server is queried from a telnet session, it is properly
supplying the namespaces

Connected to ****.****.** (***.***.***.***).
Escape character is '^]'.
* OK somehost.somedomain.com Cyrus IMAP4 2.2.12-6.fc4 server ready
. LOGIN ****** *****
. OK User logged in
. NAMESPACE
* NAMESPACE (("INBOX/" "/")) (("user/" "/")) (("" "/"))
. OK Completed
. LOGOUT
* BYE LOGOUT received
. OK Completed

Connection closed by foreign host.
Comment 1 Michael Neuhauser 2007-03-27 07:45:41 EDT
Encountered the same problem, but only if account was created with FC6's
evolution. Folders outside of INBOX are shown by FC6's evolution if the account
was created with FC4's evolution. Comparing both entries in 
~/.gconf/apps/evolution/mail/%gconf.xml showed that the working entry has
"override_namespace;namespace" in '<url>...</url>' while the newly created
account only has "override_namespace". Adding ";namespace" with the gconf-editor
fixed the problem with the new account. 
Comment 2 Matthew Barnes 2007-10-02 19:48:28 EDT
I seem to recall this being fixed awhile back.  Can you please check whether
this is fixed in Fedora 7 or later?
Comment 3 Matěj Cepl 2007-12-10 16:48:04 EST
Fedora Core 6 is no longer supported, could you please reproduce this with the
updated version of the currently supported distribution (Fedora 7, 8, or
Rawhide)? If this issue turns out to still be reproducible, please let us know
in this bug report. If after a month's time we have not heard back from you, we
will have to close this bug as CANTFIX.

Setting status to NEEDINFO, and awaiting information from the reporter.

[This is mass-filed message to all open Fedora Core 6 bugs related to Evolution.
If you see any other reason, why this bug shouldn't be closed, please,
comment on it here.]
Comment 4 Dwayne McGarty 2007-12-14 16:26:13 EST
Created a clean account and tried this with Fedora 8.  The problem remains in
this version of the distro as well.
Comment 5 Matthew Barnes 2008-03-11 22:57:02 EDT
Moving this upstream.  Please see [1] for further updates.

[1] http://bugzilla.gnome.org/show_bug.cgi?id=317178

Note You need to log in before you can comment on or make changes to this bug.