Bug 218201 - virt-manager should show size of a disk file when typing a path
virt-manager should show size of a disk file when typing a path
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: virt-manager (Show other bugs)
6
i386 Linux
medium Severity low
: ---
: ---
Assigned To: Hugh Brock
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-03 00:04 EST by Bernard Johnson
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: virt-manager-0.4.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-18 14:36:38 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bernard Johnson 2006-12-03 00:04:55 EST
Description of problem:
That's a horrible description, but I'm not sure how to word it in one line.

When you create a new Xen instance, you are walked through the creation screens.
 At "Assigning Storage Space", if you select "Simple File", and type the path
name, the "File Size" indicator is updated as you type, implying that it is
displaying timely relevent information.  If what you have typed is a valid
non-existing path, you can choose the size.  If it's a directory or an existing
file, the "File Size" is disabled because you can't set it.

When you select an existing file, it should update to show the size of the file
you have selected.

I realize that it says "Note: File size parameter is only relevent for new
files" and it would remain so if this change were made, however, it would at
least display correct information for the file selected.

Version-Release number of selected component (if applicable):
virt-manager-0.2.6-1.fc6

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
  
Actual results:
File Size is always displayed as "2000" the default, not matter which file you
have selected.

Expected results:
Display size of file.

Additional info:
Comment 1 Daniel Berrange 2006-12-03 09:51:06 EST
Yes, this behaviour is a little wierd. We need to display size of the existing
file, rather than then default. We should also validate that the selected file
is actually a file (or does not exist) - to catch case of someone entering a
directory.
Comment 2 Hugh Brock 2006-12-07 17:08:20 EST
Fixed upstream at:

http://hg.et.redhat.com/virt/applications/virt-manager--devel?cs=795d0dea350d

The file size widget now reflects the size of a file chosen either with the file
chooser dialog or by typing the path manually. Also, the wizard complains if a
user enters a directory instead of a new or existing file.

Note You need to log in before you can comment on or make changes to this bug.