Note: This bug is displayed in read-only format because the product is no longer active in Red Hat Bugzilla.
RHEL Engineering is moving the tracking of its product development work on RHEL 6 through RHEL 9 to Red Hat Jira (issues.redhat.com). If you're a Red Hat customer, please continue to file support cases via the Red Hat customer portal. If you're not, please head to the "RHEL project" in Red Hat Jira and file new tickets here. Individual Bugzilla bugs in the statuses "NEW", "ASSIGNED", and "POST" are being migrated throughout September 2023. Bugs of Red Hat partners with an assigned Engineering Partner Manager (EPM) are migrated in late September as per pre-agreed dates. Bugs against components "kernel", "kernel-rt", and "kpatch" are only migrated if still in "NEW" or "ASSIGNED". If you cannot log in to RH Jira, please consult article #7032570. That failing, please send an e-mail to the RH Jira admins at rh-issues@redhat.com to troubleshoot your issue as a user management inquiry. The email creates a ServiceNow ticket with Red Hat. Individual Bugzilla bugs that are migrated will be moved to status "CLOSED", resolution "MIGRATED", and set with "MigratedToJIRA" in "Keywords". The link to the successor Jira issue will be found under "Links", have a little "two-footprint" icon next to it, and direct you to the "RHEL project" in Red Hat Jira (issue links are of type "https://issues.redhat.com/browse/RHEL-XXXX", where "X" is a digit). This same link will be available in a blue banner at the top of the page informing you that that bug has been migrated.

Bug 2182029

Summary: messagebus not available for teamd start - Error message content: "The name org.libteam.teamd.nm-team was not provided by any .service files"
Product: Red Hat Enterprise Linux 8 Reporter: Anthony Hogbin <ahogbin>
Component: NetworkManagerAssignee: Beniamino Galvani <bgalvani>
Status: CLOSED ERRATA QA Contact: Matej Berezny <mberezny>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 8.7CC: bgalvani, djasa, ferferna, lrintel, mberezny, network-qe, pdwyer, rkhan, sfaye, sukulkar, till, vbenes
Target Milestone: rcKeywords: Triaged
Target Release: ---Flags: pm-rhel: mirror+
Hardware: x86_64   
OS: Linux   
Whiteboard:
Fixed In Version: NetworkManager-1.40.16-5.el8 Doc Type: No Doc Update
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2023-11-14 15:49:35 UTC Type: Bug
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Embargoed:

Description Anthony Hogbin 2023-03-27 10:53:26 UTC
## Description of problem:
 - Error being thrown in logging while booting
 - "libteamdctl: cli_dbus_check_error_msg: dbus: Error message content: "The name org.libteam.teamd.nm-team was not provided by any .service files"
 - dbus, team, interface, all working without issue once booted.


## Version-Release number of selected component (if applicable):
 - RHEL 8.7


## How reproducible:
 - Every time.


## Steps to Reproduce:
 1. Add team device to vanilla install;
 2. Reboot;
 3. Check logs.


## Actual results:
~~~
  Mar 27 10:46:37 rhel8-7.home NetworkManager[950]: libteamdctl: cli_dbus_check_error_msg: dbus: Error message received: "org.freedesktop.DBus.Error.ServiceUnknown"
  Mar 27 10:46:37 rhel8-7.home NetworkManager[950]: libteamdctl: cli_dbus_check_error_msg: dbus: Error message content: "The name org.libteam.teamd.nm-team was not provided by any .service files"
  Mar 27 10:46:37 rhel8-7.home NetworkManager[950]: libteamdctl: teamdctl_connect: Failed to connect using CLI "dbus".
  Mar 27 10:46:37 rhel8-7.home NetworkManager[950]: libteamdctl: teamdctl_connect: Failed to connect using all CLIs.
~~~


## Expected results:
 - No Errors being thrown.


## Additional info:
 - Looks very similar to https://access.redhat.com/solutions/107183 | Login to the server gives error "org.freedesktop.DBus.Error.ServiceUnknown: The name com.redhat.oddjob was not provided by any .service files"

 - **New behaviour** - this was not occurring in RHEL 8.6.

Comment 3 Beniamino Galvani 2023-04-26 15:55:11 UTC
> Hi, Beniamino, can you please take a look at this in NM?

Hi, the problem seems to be that NM tries to create a generated connection reading the teamd configuration even if teamd is not running.

It is a bug that an error message gets logged when the interface is brought up successfully; can you please reassign this bz to NetworkManager (unless you think something should be done it libteam)? Thanks.

Since the issue is easily reproducible, I don't think we need more information at this moment.

Comment 7 David Jaša 2023-10-17 12:16:30 UTC
This bug started failed again in the CI in supposedly fixed build, it's being tracked in Jira here: https://issues.redhat.com/browse/RHEL-14016

Comment 9 errata-xmlrpc 2023-11-14 15:49:35 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory (NetworkManager bug fix and enhancement update), and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2023:7118