Bug 21825 - Error when initialising bash in a terminal window
Summary: Error when initialising bash in a terminal window
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: bash   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-12-06 20:52 UTC by alan.hughes4
Modified: 2007-04-18 16:30 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-12-06 20:52:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description alan.hughes4 2000-12-06 20:52:43 UTC
On a vanilla install of RH 7.0, when starting bash in a KDE terminal 
window the following message appears:

    Bad : modifier in $ (/)

Not all environment variables are set up after this has occured.

Starting bash again *does not* result in the error message, and all 
environment variables are correctly set. I therefore conclude that this is 
a situation associated with the special case of bash running the 
initialisation scripts without environment variables having been set up.

I have checked all the scripts that appear to be run, and nothing stands 
out as being obviously wrong. Therefore I'd like to toss this in your lap.

Similar behaviour has been observed when starting tcsh under identical 
conditions. This behaviour was not observed under previous RH releases.

Comment 1 Bernhard Rosenkraenzer 2000-12-12 17:04:45 UTC
I can't reproduce this; it's probably caused by customized startup scripts.


Comment 2 alan.hughes4 2000-12-12 18:22:04 UTC
As stated in the original bug report, this is a *vanilla* install of RH 7.0 (to 
be specific Delux Edition boxed set - not a downloaded version). No 
customisations had been performed when the problem was first identified. Since 
then I've attempted to locate the faulty script, but have not had any luck so 
far.


Note You need to log in before you can comment on or make changes to this bug.