Bug 218264 - Too many russian keyboard layouts offered by anaconda installer
Too many russian keyboard layouts offered by anaconda installer
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: rhpl (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Chris Lumens
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-04 04:15 EST by Victor Ashik
Modified: 2007-11-30 17:11 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-12-05 10:11:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Victor Ashik 2006-12-04 04:15:40 EST
Description of problem:

Anaconda installer offers too many variants of Russian keyboard layout.
I think all but one of them are obsolete variants of KOI8-R layout, and should
be removed or hidden, because only UTF-8 layout (Russian) works after setup.


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Boot from setup media
2. Choose Russian language
3.
  
Actual results:
Offers many variants of russian keyboard layouts.
Only one variant (default one) will work after setup.

Expected results:
Only one variant offered.

Additional info:
Comment 1 Chris Lumens 2006-12-04 16:31:41 EST
The ru.map.utf8ru keyboard layout (labeled as "Russian (utf8ru)") is the only
working one?
Comment 2 Victor Ashik 2006-12-04 17:37:39 EST
No, ru.map.utf8ru is missing: system-config-keyboard gives me "cannot open file
ru.map.utf8ru" message, and find /lib/kbd -name 'ru*' proves it.

The only working one is ru.map, labeled Russian.
Comment 3 Victor Ashik 2006-12-04 17:44:23 EST
I must note, that there are still some cases for using single byte encodings
KOI8-R and windows-1251 with Fedora. So I think we should not remove keyboard
layouts completely, just hide them from installer and system-config-keyboard to
save regular user from encodings hell.
Comment 4 Chris Lumens 2006-12-05 10:11:32 EST
This will be fixed in the next build of rhpl.  Thanks for the information.

Note You need to log in before you can comment on or make changes to this bug.