Bug 218284 - Connection fails - permission problem?
Connection fails - permission problem?
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: freenx (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Axel Thimm
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-04 08:43 EST by Adam Huffman
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version: 0.6.0-12
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-06-13 18:17:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Adam Huffman 2006-12-04 08:43:22 EST
Description of problem:
I upgraded a system to FC6 (partly in order to be able to run newer FreeNX
versions) and now connections to that system using nxclient aren't working.

Version-Release number of selected component (if applicable):
freenx-0.5.0-5.fc6

How reproducible:
Every time

Steps to Reproduce:
1. Initiate connection using nxclient
2.
3.
  
Actual results:

The connection fails.  Here's the relevant log output:

NX> 596 Session startup failed.
NX> 1004 Error: NX Agent exited with exit status 1.
NX> 1006 Session status: closed
NX> 105 Can't open
/var/lib/nxserver/db/running/sessionId{5E837C5B7890E545FE383D49EA26166C}: No
such file or directory.
mv: cannot stat
`/var/lib/nxserver/db/running/sessionId{5E837C5B7890E545FE383D49EA26166C}': No
such file or directory
/usr/bin/nxserver: line 1077:  1137 Terminated              sleep
$AGENT_STARTUP_TIMEOUT
Killed by signal 15.

Expected results:
The connection should succeed.

Additional info:
Comment 1 Adam Huffman 2006-12-04 11:47:38 EST
Further testing reveals that this problem seems to be restricted to GNOME
sessions.  When I use KDE, the connection succeeds.
Comment 2 Axel Thimm 2007-05-19 10:23:58 EDT
This is a collective bugzilla comment for nx/freenx bugs.

New versions of nx and freenx have entered the repos. Please check if the bug
report is still valid with the new versions (freenx-0.6.0-12 and nx-2.1.0-19).
Comment 3 Adam Huffman 2007-06-13 18:17:04 EDT
Haven't seen this recently, so I'll close the bug.

Note You need to log in before you can comment on or make changes to this bug.