Bug 218384 - Sound problem with plugged front and rear sockets
Sound problem with plugged front and rear sockets
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: alsa-lib (Show other bugs)
6
All Linux
medium Severity medium
: ---
: ---
Assigned To: Martin Stransky
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2006-12-04 18:30 EST by Gf Durin
Modified: 2007-11-30 17:11 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-04-10 08:49:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gf Durin 2006-12-04 18:30:13 EST
Description of problem:
I discovered a very strange bug where there a two sockets used for sound. For
instance, I have a couple of loudspeakers connected to the rear socket and they
work fine, the sound is perfect.
If I plug the headphones (for instance) into the front socket, the rear sound
gets off (as it has to), but the sound from the headphones is really bad. But if
I unplug it a little (as if only one channel is used) the sound is fine again
(even if not perfect).
When completely plugged-in, the sound is again quite good only if I unbalance a
little right and left, or better if one is off (using the master settings). 

It seems to be still a stereo sound (not sure, by the way), and well balanced

Version-Release number of selected component (if applicable):
alsa-lib-1.0.12-2.fc6
alsa-utils-1.0.12-3.fc6

How reproducible:
Always
I have two different PCs, with different sound cards, different loud speakers,
different headphones and the effect is the same.  

Steps to Reproduce:
1. Use fron and rear sockets at the same time
2. Balance and unbalance the master settings
3.
  
Actual results:
Bad sound from front socket

Expected results:


Additional info:
I am not sure, but this seems to occurs only recently (say 15-20 days). I update
the system every day.
Comment 1 Martin Stransky 2006-12-14 05:39:58 EST
okay, could you please check the latest drivers / packages? (ALSA 1.0.14rc1)
How-to is here:

http://people.redhat.com/stransky/alsa/
Comment 2 malcolm 2006-12-21 09:51:20 EST
Variation but possibly related

If I run the sound detection or play sound and push
the headphone or speaker socket ALMOST home the sound
works fine out of the front or the back sockets . If I push the
plug completely home so it clicks the sound stops. It is as
if clicking it in makes the hardware detect it which sends
some signal that confuses alsa ( box dual boots to XP which
works fine ...! )

This is a white box with all Intel chip sets - the sound card
is detected as 82801G ICH7 Family High Definition Audio Controller

Comment 3 malcolm 2006-12-21 12:46:59 EST
Did the driver upgrade as per "Comment 1" and it now works
Comment 4 Martin Stransky 2007-04-10 08:49:42 EDT
great, thanks.

Note You need to log in before you can comment on or make changes to this bug.